aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-05-02 11:29:53 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-05-02 11:29:53 +0000
commit6ac2050304a1ed356ff08f6babf20a33b99bc38b (patch)
tree7adaa4155313d594fd46e138dfa1f3e39775c354 /package
parent1d4db4520ab1c4e7472a48d14ec641e2ef074b6b (diff)
downloadmaster-187ad058-6ac2050304a1ed356ff08f6babf20a33b99bc38b.tar.gz
master-187ad058-6ac2050304a1ed356ff08f6babf20a33b99bc38b.tar.bz2
master-187ad058-6ac2050304a1ed356ff08f6babf20a33b99bc38b.zip
[package] IMQ is not yet available on 2.6.25
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11007 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/iptables/Makefile2
-rw-r--r--package/kernel/modules/netfilter.mk1
2 files changed, 2 insertions, 1 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index ff55ce590a..9d6d8f8423 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -88,7 +88,7 @@ define Package/iptables-mod-filter/description
endef
define Package/iptables-mod-imq
-$(call Package/iptables/Module, +kmod-ipt-imq)
+$(call Package/iptables/Module, +kmod-ipt-imq @!LINUX_2_6_25)
TITLE:=IMQ support
endef
diff --git a/package/kernel/modules/netfilter.mk b/package/kernel/modules/netfilter.mk
index e753fb24fe..3eeb7aa6a0 100644
--- a/package/kernel/modules/netfilter.mk
+++ b/package/kernel/modules/netfilter.mk
@@ -156,6 +156,7 @@ define KernelPackage/ipt-imq
SUBMENU:=$(NF_MENU)
TITLE:=Intermediate Queueing support
KCONFIG:=CONFIG_IP_NF_TARGET_IMQ
+ DEPENDS:=@!LINUX_2_6_25
FILES:=$(LINUX_DIR)/net/ipv4/netfilter/*IMQ*.$(LINUX_KMOD_SUFFIX) $(LINUX_DIR)/drivers/net/imq.$(LINUX_KMOD_SUFFIX)
AUTOLOAD:=$(call AutoLoad,40,$(notdir $(patsubst %.ko,%,$(wildcard $(LINUX_DIR)/net/ipv4/netfilter/*IMQ*.$(LINUX_KMOD_SUFFIX) $(LINUX_DIR)/drivers/net/imq.$(LINUX_KMOD_SUFFIX)))))
endef