aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorZoltan Herpai <wigyori@uid0.hu>2016-11-10 16:12:32 +0100
committerGitHub <noreply@github.com>2016-11-10 16:12:32 +0100
commit2f73d1f5e5cd7c5e98fa838e61bfa4030ad0fc40 (patch)
tree5447a8334b4cac983581d4ab9f73682c23b14f67 /package
parentcedab88a4379aebeb3dbd7cc420bb4a13874eef1 (diff)
parentdc5d9e714a15b8130f0d2a79f54d4f7132f39a28 (diff)
downloadmaster-187ad058-2f73d1f5e5cd7c5e98fa838e61bfa4030ad0fc40.tar.gz
master-187ad058-2f73d1f5e5cd7c5e98fa838e61bfa4030ad0fc40.tar.bz2
master-187ad058-2f73d1f5e5cd7c5e98fa838e61bfa4030ad0fc40.zip
Merge pull request #199 from seragh/owrt-firewall-2016-11-06
firewall version bump to 2016-11-06 and xt_id removal
Diffstat (limited to 'package')
-rw-r--r--package/network/config/firewall/Makefile7
-rw-r--r--package/network/utils/iptables/patches/500-add-xt_id-match.patch69
2 files changed, 3 insertions, 73 deletions
diff --git a/package/network/config/firewall/Makefile b/package/network/config/firewall/Makefile
index 73dae29468..f9fa9116b6 100644
--- a/package/network/config/firewall/Makefile
+++ b/package/network/config/firewall/Makefile
@@ -8,15 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=firewall
-PKG_VERSION:=2016-01-29
-PKG_RELEASE:=$(PKG_SOURCE_VERSION)
+PKG_VERSION:=2016-11-06
+PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(OPENWRT_GIT)/project/firewall3.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=8957be6c026858fe414aef69281d8aa06f7ea122
+PKG_SOURCE_VERSION:=bd40ba4584141ce34f3d5c42841abafccad06bdd
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
-PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
PKG_LICENSE:=ISC
PKG_CONFIG_DEPENDS := CONFIG_IPV6
diff --git a/package/network/utils/iptables/patches/500-add-xt_id-match.patch b/package/network/utils/iptables/patches/500-add-xt_id-match.patch
deleted file mode 100644
index 0964f0175f..0000000000
--- a/package/network/utils/iptables/patches/500-add-xt_id-match.patch
+++ /dev/null
@@ -1,69 +0,0 @@
---- /dev/null
-+++ b/extensions/libxt_id.c
-@@ -0,0 +1,55 @@
-+/* Shared library add-on to iptables to add id match support. */
-+
-+#include <stdio.h>
-+#include <xtables.h>
-+#include <linux/netfilter/xt_id.h>
-+
-+enum {
-+ O_ID = 0,
-+};
-+
-+static const struct xt_option_entry id_opts[] = {
-+ {
-+ .name = "id",
-+ .id = O_ID,
-+ .type = XTTYPE_UINT32,
-+ .flags = XTOPT_MAND | XTOPT_PUT,
-+ XTOPT_POINTER(struct xt_id_info, id)
-+ },
-+ XTOPT_TABLEEND,
-+};
-+
-+static void
-+id_print(const void *ip, const struct xt_entry_match *match, int numeric)
-+{
-+ struct xt_id_info *idinfo = (void *)match->data;
-+
-+ printf(" ID:%08lx", idinfo->id);
-+}
-+
-+
-+/* Saves the union ipt_matchinfo in parsable form to stdout. */
-+static void
-+id_save(const void *ip, const struct xt_entry_match *match)
-+{
-+ struct xt_id_info *idinfo = (void *)match->data;
-+
-+ printf(" --id 0x%lx", idinfo->id);
-+}
-+
-+static struct xtables_match id_match = {
-+ .family = NFPROTO_UNSPEC,
-+ .name = "id",
-+ .version = XTABLES_VERSION,
-+ .size = XT_ALIGN(sizeof(struct xt_id_info)),
-+ .userspacesize = XT_ALIGN(sizeof(struct xt_id_info)),
-+ .print = id_print,
-+ .save = id_save,
-+ .x6_parse = xtables_option_parse,
-+ .x6_options = id_opts,
-+};
-+
-+void _init(void)
-+{
-+ xtables_register_match(&id_match);
-+}
---- /dev/null
-+++ b/include/linux/netfilter/xt_id.h
-@@ -0,0 +1,8 @@
-+#ifndef _XT_ID_H
-+#define _XT_ID_H
-+
-+struct xt_id_info {
-+ __u32 id;
-+};
-+
-+#endif /* XT_ID_H */