aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-05-26 08:43:52 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-05-26 08:43:52 +0000
commit2c85313ae2d4ebd7ac83c9904778ee29586ae117 (patch)
treedbaeb5898447fceedb4de028945b1c980e2788c1 /package
parente1bc7b5ab1e5892966b6828114775ffe66654a65 (diff)
downloadmaster-187ad058-2c85313ae2d4ebd7ac83c9904778ee29586ae117.tar.gz
master-187ad058-2c85313ae2d4ebd7ac83c9904778ee29586ae117.tar.bz2
master-187ad058-2c85313ae2d4ebd7ac83c9904778ee29586ae117.zip
[package] allow ar7-atm annex a and b co-existence by symlinking firmwares
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16071 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/ar7-atm/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/package/ar7-atm/Makefile b/package/ar7-atm/Makefile
index f8ae39298d..fafc44eedd 100644
--- a/package/ar7-atm/Makefile
+++ b/package/ar7-atm/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -54,12 +54,14 @@ endef
define KernelPackage/sangam-atm-annex-a/install
mkdir -p $(1)/lib/firmware
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/ar0700mp.bin $(1)/lib/firmware/ar0700xx.bin
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/ar0700mp.bin $(1)/lib/firmware/
+ ln -sf ar0700mp.bin $(1)/lib/firmware/ar0700xx.bin
endef
define KernelPackage/sangam-atm-annex-b/install
mkdir -p $(1)/lib/firmware
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/ar0700db.bin $(1)/lib/firmware/ar0700xx.bin
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/ar0700db.bin $(1)/lib/firmware/
+ ln -sf ar0700db.bin $(1)/lib/firmware/ar0700xx.bin
endef
$(eval $(call KernelPackage,sangam-atm-annex-a))