aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-06-02 22:57:33 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-06-02 22:57:33 +0000
commit2053d4546c919063327559f9865f058adfff961e (patch)
tree5a84932826cbdb1bdae2e3abaa3f833f79de4f93 /package
parenta861c957f9ddb80022b5176ed6d4c6d91c666967 (diff)
downloadmaster-187ad058-2053d4546c919063327559f9865f058adfff961e.tar.gz
master-187ad058-2053d4546c919063327559f9865f058adfff961e.tar.bz2
master-187ad058-2053d4546c919063327559f9865f058adfff961e.zip
Add iprange (#1799)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7462 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/iptables/Makefile12
-rw-r--r--package/kernel/modules/netfilter.mk13
2 files changed, 25 insertions, 0 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index 7d34cc68ee..bd85322ff3 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -133,6 +133,17 @@ define Package/iptables-mod-ulog
- libipt_ULOG
endef
+define Package/iptables-mod-iprange
+ $(call Package/iptables/Default)
+ DEPENDS:=iptables +kmod-ipt-iprange
+ TITLE:=ip range module
+ DESCRIPTION:=\
+ iptables extensions for matching ip ranges.\\\
+ \\\
+ Includes: \\\
+ - libipt_iprange
+endef
+
define Package/iptables-mod-extra
$(call Package/iptables/Default)
DEPENDS:=iptables +kmod-ipt-extra
@@ -257,5 +268,6 @@ $(eval $(call BuildPlugin,iptables-mod-imq,$(IPT_IMQ-m)))
$(eval $(call BuildPlugin,iptables-mod-ipopt,$(IPT_IPOPT-m)))
$(eval $(call BuildPlugin,iptables-mod-ipsec,$(IPT_IPSEC-m)))
$(eval $(call BuildPlugin,iptables-mod-nat,$(IPT_NAT-m)))
+$(eval $(call BuildPlugin,iptables-mod-iprange,$(IPT_IPRANGE-m)))
$(eval $(call BuildPlugin,iptables-mod-ulog,$(IPT_ULOG-m)))
$(eval $(call BuildPackage,ip6tables))
diff --git a/package/kernel/modules/netfilter.mk b/package/kernel/modules/netfilter.mk
index 18f9203a47..d3b3396e86 100644
--- a/package/kernel/modules/netfilter.mk
+++ b/package/kernel/modules/netfilter.mk
@@ -161,6 +161,19 @@ define KernelPackage/ipt-ulog
endef
$(eval $(call KernelPackage,ipt-ulog))
+define KernelPackage/ipt-iprange
+ TITLE:=Module for matching ip ranges
+ DESCRIPTION:=\
+ Netfilter (IPv4) module for matching ip ranges \\\
+ \\\
+ Includes: \\\
+ - ipt_IPRANGE
+ FILES:=$(LINUX_DIR)/net/ipv4/netfilter/ipt_iprange.$(LINUX_KMOD_SUFFIX)
+ SUBMENU:=$(NFMENU)
+ AUTOLOAD:=$(call AutoLoad,40,$(notdir $(IPT_IPRANGE-m)))
+endef
+$(eval $(call KernelPackage,ipt-iprange))
+
define KernelPackage/ipt-extra
TITLE:=Extra modules
DESCRIPTION:=\