aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-08-07 16:08:11 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-08-07 16:08:11 +0000
commit1d37d67df3362f2d922d285d08e7492ab3d0538e (patch)
tree1e81d9bddaf45ebd6b86c334d3e0d9bfcdd24dff /package
parent136aed85e3e522fb89e053641cb42ae8875b0098 (diff)
downloadmaster-187ad058-1d37d67df3362f2d922d285d08e7492ab3d0538e.tar.gz
master-187ad058-1d37d67df3362f2d922d285d08e7492ab3d0538e.tar.bz2
master-187ad058-1d37d67df3362f2d922d285d08e7492ab3d0538e.zip
[package] busybox: support V=c toplevel verboseness flag (#11799)
Signed-off-by: Gregory M. Turner <gmt@malth.us> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33035 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/busybox/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index ef7f51877b..13aa28945d 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -26,6 +26,12 @@ ifeq ($(DUMP),)
STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell $(SH_FUNC) grep '^CONFIG_BUSYBOX_' $(TOPDIR)/.config | md5s)
endif
+ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)
+ BB_MAKE_VERBOSE := V=1
+else
+ BB_MAKE_VERBOSE :=
+endif
+
init-y :=
init-$(CONFIG_BUSYBOX_CONFIG_HTTPD) += httpd
init-$(CONFIG_BUSYBOX_CONFIG_CROND) += cron
@@ -58,6 +64,7 @@ define Build/Configure
CROSS_COMPILE="$(TARGET_CROSS)" \
KBUILD_HAVE_NLS=no \
ARCH="$(ARCH)" \
+ $(BB_MAKE_VERBOSE) \
oldconfig
endef
@@ -81,6 +88,7 @@ define Build/Compile
ARCH="$(ARCH)" \
SKIP_STRIP=y \
LDLIBS="$(LDLIBS)" \
+ $(BB_MAKE_VERBOSE) \
all
rm -rf $(PKG_INSTALL_DIR)
$(FIND) $(PKG_BUILD_DIR) -lname "*busybox" -exec rm \{\} \;
@@ -91,6 +99,7 @@ define Build/Compile
ARCH="$(ARCH)" \
CONFIG_PREFIX="$(PKG_INSTALL_DIR)" \
LDLIBS="$(LDLIBS)" \
+ $(BB_MAKE_VERBOSE) \
install
endef