aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-01-12 11:58:41 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-01-12 11:58:41 +0000
commit1a87ce75daa1cd210394993c28eca0739b6888c8 (patch)
tree1f7fe78e17bee83a80162939500ff9f45fdc9fda /package
parent9f1844bffb8b14de38d615d8b713d433a8824d60 (diff)
downloadmaster-187ad058-1a87ce75daa1cd210394993c28eca0739b6888c8.tar.gz
master-187ad058-1a87ce75daa1cd210394993c28eca0739b6888c8.tar.bz2
master-187ad058-1a87ce75daa1cd210394993c28eca0739b6888c8.zip
pwm support can't be compiled as a module
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43947 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/hwmon.mk2
-rw-r--r--package/kernel/linux/modules/other.mk14
2 files changed, 1 insertions, 15 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index 74af38b49a..5408b6d5a2 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -295,7 +295,7 @@ define KernelPackage/hwmon-pwmfan
KCONFIG:=CONFIG_SENSORS_PWM_FAN
FILES:=$(LINUX_DIR)/drivers/hwmon/pwm-fan.ko
AUTOLOAD:=$(call AutoLoad,60,pwm-fan)
- $(call AddDepends/hwmon,+kmod-pwm)
+ $(call AddDepends/hwmon,)
DEPENDS+=@!LINUX_3_3 @!LINUX_3_8 @!LINUX_3_10 @!LINUX_3_14
endef
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index b1bb76a892..eed258dc22 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -495,20 +495,6 @@ endef
$(eval $(call KernelPackage,booke-wdt))
-define KernelPackage/pwm
- SUBMENU:=$(OTHER_MENU)
- TITLE:=PWM generic API
- KCONFIG:=CONFIG_GENERIC_PWM
- FILES:=$(LINUX_DIR)/drivers/pwm/pwm.ko
-endef
-
-define KernelPackage/pwm/description
- Kernel module that implement a generic PWM API
-endef
-
-$(eval $(call KernelPackage,pwm))
-
-
define KernelPackage/rtc-ds1307
SUBMENU:=$(OTHER_MENU)
TITLE:=Dallas/Maxim DS1307 (and compatible) RTC support