aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-12-14 13:40:21 +0000
committerNicolas Thill <nico@openwrt.org>2005-12-14 13:40:21 +0000
commit14d8d65d9831bb617d22889c9175d7506ecbdc0e (patch)
tree9c5b5b80ed222c229734b87d0fb1824c0e459ca3 /package
parent150f2e49687c8798720af18ef3d7d3c04a959a45 (diff)
downloadmaster-187ad058-14d8d65d9831bb617d22889c9175d7506ecbdc0e.tar.gz
master-187ad058-14d8d65d9831bb617d22889c9175d7506ecbdc0e.tar.bz2
master-187ad058-14d8d65d9831bb617d22889c9175d7506ecbdc0e.zip
add madplay package (thanks to Romain Beauxis),
add libid3tag dependency on zlib. git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2670 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/Config.in1
-rw-r--r--package/Makefile3
-rw-r--r--package/madplay/Config.in12
-rw-r--r--package/madplay/Makefile78
-rw-r--r--package/madplay/ipkg/madplay.control6
5 files changed, 100 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index aa91d43e66..e907f21ae0 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -223,6 +223,7 @@ source "package/zlib/Config.in"
comment "Multimedia"
source "package/gmediaserver/Config.in"
source "package/icecast/Config.in"
+source "package/madplay/Config.in"
source "package/mpd/Config.in"
source "package/mt-daapd/Config.in"
source "package/palantir/Config.in"
diff --git a/package/Makefile b/package/Makefile
index c83949f468..2aab555fdb 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -110,6 +110,7 @@ package-$(BR2_PACKAGE_LIBXSLT) += libxslt
package-$(BR2_PACKAGE_LIGHTTPD) += lighttpd
package-$(BR2_PACKAGE_LINUX_ATM) += linux-atm
package-$(BR2_COMPILE_LUA) += lua
+package-$(BR2_PACKAGE_MADPLAY) += madplay
package-$(BR2_PACKAGE_MADWIFI_TOOLS) += madwifi-tools
package-$(BR2_PACKAGE_MARADNS) += maradns
package-$(BR2_COMPILE_MATRIXSSL) += matrixssl
@@ -274,12 +275,14 @@ less-compile: ncurses-compile
lcd4linux-compile: ncurses-compile
libgcrypt-compile: libgpg-error-compile
libgd-compile: libpng-compile
+libid3tag-compile: zlib-compile
libnet-compile: libpcap-compile
libnids-compile: libnet-compile
libvorbis-compile: libogg-compile
libxml2-compile: zlib-compile
libxslt-compile: libxml2-compile
lighttpd-compile: openssl-compile pcre-compile
+madplay-compile: libid3tag-compile libmad-compile
miax-compile: bluez-libs-compile
miredo-compile: uclibc++-compile
mt-daapd-compile: howl-compile libgdbm-compile libid3tag-compile
diff --git a/package/madplay/Config.in b/package/madplay/Config.in
new file mode 100644
index 0000000000..59e234668e
--- /dev/null
+++ b/package/madplay/Config.in
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_MADPLAY
+ tristate "madplay........................... MPEG audio player in fixed point"
+ default m if CONFIG_DEVELOPER
+ select BR2_PACKAGE_LIBID3TAG
+ select BR2_PACKAGE_LIBMAD
+ help
+ MAD is an MPEG audio decoder. It currently only supports the MPEG 1
+ standard, but fully implements all three audio layers (Layer I, Layer II,
+ and Layer III, the latter often colloquially known as MP3.). There is also
+ full support for ID3 tags.
+
+
diff --git a/package/madplay/Makefile b/package/madplay/Makefile
new file mode 100644
index 0000000000..15ddd14273
--- /dev/null
+++ b/package/madplay/Makefile
@@ -0,0 +1,78 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=madplay
+PKG_VERSION:=0.15.2b
+PKG_RELEASE:=1
+PKG_MD5SUM:=6814b47ceaa99880c754c5195aa1aac1
+
+PKG_SOURCE_URL:=@SF/mad \
+ ftp://ftp.mars.org/pub/mpeg/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,MADPLAY,madplay,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+ (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+ BUILD_CC=$(TARGET_CC) HOSTCC=$(HOSTCC) \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+ LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+ LIBS="-lz" \
+ ac_cv_linux_vers=2 \
+ td_cv_buggygetaddrinfo="no" \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --program-prefix="" \
+ --program-suffix="" \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --datadir=/usr/share \
+ --includedir=/usr/include \
+ --infodir=/usr/share/info \
+ --libdir=/usr/lib \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --mandir=/usr/share/man \
+ --sbindir=/usr/sbin \
+ --sysconfdir=/etc \
+ $(DISABLE_LARGEFILE) \
+ $(DISABLE_NLS) \
+ --enable-shared \
+ --disable-static \
+ --with-gnu-ld \
+ --disable-rpath \
+ --disable-debugging \
+ --disable-profiling \
+ --disable-experimental \
+ --without-libiconv-prefix \
+ --without-libintl-prefix \
+ --without-alsa \
+ --without-esd \
+ );
+ touch $@
+
+$(PKG_BUILD_DIR)/.built:
+ rm -rf $(PKG_INSTALL_DIR)
+ mkdir -p $(PKG_INSTALL_DIR)
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ DESTDIR="$(PKG_INSTALL_DIR)" \
+ all install
+ touch $@
+
+$(IPKG_MADPLAY):
+ install -m0755 -d $(IDIR_MADPLAY)/usr/bin
+ install -m0755 $(PKG_INSTALL_DIR)/usr/bin/madplay $(IDIR_MADPLAY)/usr/bin/
+ $(RSTRIP) $(IDIR_MADPLAY)
+ $(IPKG_BUILD) $(IDIR_MADPLAY) $(PACKAGE_DIR)
diff --git a/package/madplay/ipkg/madplay.control b/package/madplay/ipkg/madplay.control
new file mode 100644
index 0000000000..f776e7ca63
--- /dev/null
+++ b/package/madplay/ipkg/madplay.control
@@ -0,0 +1,6 @@
+Package: madplay
+Priority: optional
+Section: sound
+Description: MPEG audio player in fixed point
+Depends: libid3tag, libmad
+