aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-09-27 10:49:33 +0000
committerLuka Perkov <luka@openwrt.org>2013-09-27 10:49:33 +0000
commit0cd0b53a959dc8dc8b857fed9f9701e8a29b7b13 (patch)
treed799dcb531fc9e4fee6a217256e5cf7655dfdb30 /package
parent2edffc93a65d552696f71421c4b2247fde954eba (diff)
downloadmaster-187ad058-0cd0b53a959dc8dc8b857fed9f9701e8a29b7b13.tar.gz
master-187ad058-0cd0b53a959dc8dc8b857fed9f9701e8a29b7b13.tar.bz2
master-187ad058-0cd0b53a959dc8dc8b857fed9f9701e8a29b7b13.zip
kernel: add thermal modules
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38230 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/other.mk63
1 files changed, 63 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 293e517821..cbce02bbf5 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -760,3 +760,66 @@ define KernelPackage/random-core/description
endef
$(eval $(call KernelPackage,random-core))
+
+
+define KernelPackage/thermal
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Generic Thermal sysfs driver
+ KCONFIG:= \
+ CONFIG_THERMAL \
+ CONFIG_THERMAL_DEFAULT_GOV_STEP_WISE=y \
+ CONFIG_THERMAL_DEFAULT_GOV_FAIR_SHARE=n \
+ CONFIG_THERMAL_DEFAULT_GOV_USER_SPACE=n \
+ CONFIG_THERMAL_GOV_FAIR_SHARE=n \
+ CONFIG_THERMAL_GOV_STEP_WISE=y \
+ CONFIG_THERMAL_GOV_USER_SPACE=n \
+ CONFIG_THERMAL_EMULATION=n
+ FILES:=$(LINUX_DIR)/drivers/thermal/thermal_sys.ko
+ AUTOLOAD:=$(call AutoProbe,thermal_sys)
+endef
+
+define KernelPackage/thermal/description
+ Generic Thermal Sysfs driver offers a generic mechanism for thermal
+ management. Usually it's made up of one or more thermal zone and cooling
+ device.
+endef
+
+$(eval $(call KernelPackage,thermal))
+
+
+define KernelPackage/thermal-armada
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Armada 370/XP thermal management
+ DEPENDS:=@TARGET_mvebu +kmod-thermal
+ KCONFIG:=CONFIG_ARMADA_THERMAL
+ FILES:=$(LINUX_DIR)/drivers/thermal/armada_thermal.ko
+ AUTOLOAD:=$(call AutoProbe,armada_thermal)
+endef
+
+define KernelPackage/thermal-armada/description
+ Enable this module if you want to have support for thermal management
+ controller present in Armada 370 and Armada XP SoC.
+endef
+
+$(eval $(call KernelPackage,thermal-armada))
+
+
+define KernelPackage/thermal-imx
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Temperature sensor driver for Freescale i.MX SoCs
+ DEPENDS:=@TARGET_imx6 +kmod-thermal
+ KCONFIG:= \
+ CONFIG_CPU_THERMAL=y \
+ CONFIG_IMX_THERMAL
+ FILES:=$(LINUX_DIR)/drivers/thermal/imx_thermal.ko
+ AUTOLOAD:=$(call AutoProbe,imx_thermal)
+endef
+
+define KernelPackage/thermal-imx/description
+ Support for Temperature Monitor (TEMPMON) found on Freescale i.MX SoCs.
+ It supports one critical trip point and one passive trip point. The
+ cpufreq is used as the cooling device to throttle CPUs when the
+ passive trip is crossed.
+endef
+
+$(eval $(call KernelPackage,thermal-imx))