aboutsummaryrefslogtreecommitdiffstats
path: root/package/yamonenv
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-07-03 13:25:25 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-07-03 13:25:25 +0000
commite7bac6dc6fb189d8c620f19348bba367c05ae423 (patch)
tree77355c12cc3f2fffa62fc2dabbd38af6256fc123 /package/yamonenv
parent18b85db06b55c9a9246d876996e65aa839aa7932 (diff)
downloadmaster-187ad058-e7bac6dc6fb189d8c620f19348bba367c05ae423.tar.gz
master-187ad058-e7bac6dc6fb189d8c620f19348bba367c05ae423.tar.bz2
master-187ad058-e7bac6dc6fb189d8c620f19348bba367c05ae423.zip
Add yamonenv, utility to read and configure variables for the YAMON bootloader
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4116 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/yamonenv')
-rw-r--r--package/yamonenv/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/package/yamonenv/Makefile b/package/yamonenv/Makefile
new file mode 100644
index 0000000000..dfb0c82f96
--- /dev/null
+++ b/package/yamonenv/Makefile
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 4091 2006-06-27 00:35:46Z mbm $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=yamonenv
+PKG_VERSION:=20051022
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+PKG_SOURCE:=$(PKG_NAME)_gruen.4g__$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://meshcube.org/nylon/stable/sources/
+PKG_MD5SUM:=a3e4f24155aa3ba5aa502bc63fdaa6ad
+PKG_CAT:=zcat
+
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/yamonenv
+SECTION:=sys
+CATEGORY:=Base system
+DEPENDS:=@LINUX_2_6_AU1000@
+TITLE:=YAMON configuration utility
+DESCRIPTION:=YAMON bootloader configuration utility
+URL:=http://meshcube.org/nylon/stable/sources/
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+ $(call Build/Compile/Default,all)
+endef
+
+define Package/yamonenv/install
+ install -d -m0755 $(1)/usr/sbin
+ $(CP) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,yamonenv))