aboutsummaryrefslogtreecommitdiffstats
path: root/package/wput
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-05-21 02:15:53 +0000
committerNicolas Thill <nico@openwrt.org>2005-05-21 02:15:53 +0000
commit601ec75c9d069b1c3ec7aa64aecf04e5cdf11bda (patch)
tree10b83d9311efeb66914c87111d2cbc7578434e55 /package/wput
parent204ceaa626292179b19639c8a6e65f7b9e397734 (diff)
downloadmaster-187ad058-601ec75c9d069b1c3ec7aa64aecf04e5cdf11bda.tar.gz
master-187ad058-601ec75c9d069b1c3ec7aa64aecf04e5cdf11bda.tar.bz2
master-187ad058-601ec75c9d069b1c3ec7aa64aecf04e5cdf11bda.zip
Add wput package
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1004 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/wput')
-rw-r--r--package/wput/Config.in9
-rw-r--r--package/wput/Makefile60
-rw-r--r--package/wput/ipkg/wput.control8
3 files changed, 77 insertions, 0 deletions
diff --git a/package/wput/Config.in b/package/wput/Config.in
new file mode 100644
index 0000000000..8aa5ba334d
--- /dev/null
+++ b/package/wput/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_WPUT
+ tristate "wput - A wget-like command-line FTP client"
+ default m if CONFIG_DEVEL
+ help
+ A wget-like command-line FTP client.
+
+ http://itooktheredpill.dyndns.org/wput/
+
+
diff --git a/package/wput/Makefile b/package/wput/Makefile
new file mode 100644
index 0000000000..bbe8343ef1
--- /dev/null
+++ b/package/wput/Makefile
@@ -0,0 +1,60 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=wput
+PKG_VERSION:=0.5
+PKG_RELEASE:=1
+PKG_MD5SUM:=441b2e07219f78167b29a7ac33488fff
+
+PKG_SOURCE_URL:=http://itooktheredpill.dyndns.org/wput/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,WPUT,wput,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+ (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --program-prefix="" \
+ --program-suffix="" \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --datadir=/usr/share \
+ --includedir=/usr/include \
+ --infodir=/usr/share/info \
+ --libdir=/usr/lib \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --mandir=/usr/share/man \
+ --sbindir=/usr/sbin \
+ --sysconfdir=/etc \
+ $(DISABLE_LARGEFILE) \
+ $(DISABLE_NLS) \
+ --enable-shared \
+ --disable-static \
+ --disable-g-switch \
+ )
+ touch $@
+
+$(PKG_BUILD_DIR)/.built:
+ $(MAKE) -C $(PKG_BUILD_DIR)
+ touch $@
+
+$(IPKG_WPUT):
+ install -d -m0755 $(IDIR_WPUT)/usr/bin
+ install -m0755 $(PKG_BUILD_DIR)/wput $(IDIR_WPUT)/usr/bin/
+ $(RSTRIP) $(IDIR_WPUT)
+ $(IPKG_BUILD) $(IDIR_WPUT) $(PACKAGE_DIR)
+
diff --git a/package/wput/ipkg/wput.control b/package/wput/ipkg/wput.control
new file mode 100644
index 0000000000..80d6baea14
--- /dev/null
+++ b/package/wput/ipkg/wput.control
@@ -0,0 +1,8 @@
+Package: wput
+Priority: optional
+Section: net
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: Nico <nthill@free.fr>
+Source: http://nthill.free.fr/openwrt/sources/wput/
+Description: a wget-like command-line FTP client