aboutsummaryrefslogtreecommitdiffstats
path: root/package/wprobe/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-04-27 15:53:00 +0000
committerNicolas Thill <nico@openwrt.org>2009-04-27 15:53:00 +0000
commit07f45e3a7d16b94f0ef2c5e7e04f111c408cdf8d (patch)
tree090bd23485a06b25d7416926be7177c9bf4b91e5 /package/wprobe/Makefile
parentef588da41619ad44fd9ba4daafc4ee02ba17d9a1 (diff)
downloadmaster-187ad058-07f45e3a7d16b94f0ef2c5e7e04f111c408cdf8d.tar.gz
master-187ad058-07f45e3a7d16b94f0ef2c5e7e04f111c408cdf8d.tar.bz2
master-187ad058-07f45e3a7d16b94f0ef2c5e7e04f111c408cdf8d.zip
introduce a generic PKG_CONFIG_DEPENDS for packages that need to be reconfigured when certain CONFIG options changed, rename PKG_BUILD_DEPEND to PKG_BUILD_DEPENDS
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15451 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/wprobe/Makefile')
-rw-r--r--package/wprobe/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/package/wprobe/Makefile b/package/wprobe/Makefile
index bbc2b88c94..cea23d2a3b 100644
--- a/package/wprobe/Makefile
+++ b/package/wprobe/Makefile
@@ -12,13 +12,11 @@ PKG_VERSION:=1
PKG_BUILD_DEPENDS:=libnl PACKAGE_wprobe-export:libipfix
-include $(INCLUDE_DIR)/package.mk
-
-PKG_CONFDEPS = \
+PKG_CONFIG_DEPENDS = \
CONFIG_PACKAGE_kmod-wprobe \
- CONFIG_PACKAGE_wprobe-export
+ CONFIG_PACKAGE_wprobe-export \
-STAMP_CONFIGURED:=$(STAMP_CONFIGURED)_$(call confvar,$(PKG_CONFDEPS))
+include $(INCLUDE_DIR)/package.mk
define KernelPackage/wprobe
SUBMENU:=Network Support