aboutsummaryrefslogtreecommitdiffstats
path: root/package/wpa_supplicant
diff options
context:
space:
mode:
authorAndy Boyett <agb@openwrt.org>2008-07-17 01:09:49 +0000
committerAndy Boyett <agb@openwrt.org>2008-07-17 01:09:49 +0000
commitc9694199b4d8289f52bf27b9d4e5e2bc78b3e72e (patch)
treeb8bdef97508c9d8e422e4bad67240205dd99b953 /package/wpa_supplicant
parent9e7b521696118aa6f925810155c632420396ce0a (diff)
downloadmaster-187ad058-c9694199b4d8289f52bf27b9d4e5e2bc78b3e72e.tar.gz
master-187ad058-c9694199b4d8289f52bf27b9d4e5e2bc78b3e72e.tar.bz2
master-187ad058-c9694199b4d8289f52bf27b9d4e5e2bc78b3e72e.zip
[wpa_supplicant] Fix menuconfig
- Description for the no timestamp check option was swallowing all entries below it in menuconfig git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11850 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/wpa_supplicant')
-rw-r--r--package/wpa_supplicant/Config.in9
-rw-r--r--package/wpa_supplicant/Makefile8
2 files changed, 10 insertions, 7 deletions
diff --git a/package/wpa_supplicant/Config.in b/package/wpa_supplicant/Config.in
new file mode 100644
index 0000000000..d3700fae84
--- /dev/null
+++ b/package/wpa_supplicant/Config.in
@@ -0,0 +1,9 @@
+# wpa_supplicant config
+config WPA_SUPPLICANT_NO_TIMESTAMP_CHECK
+ bool "Disable timestamp check"
+ depends PACKAGE_wpa-supplicant
+ default n
+ help
+ This disables the timestamp check for certificates in wpa_supplicant
+ Useful for devices without RTC that cannot reliably get the real date/time
+
diff --git a/package/wpa_supplicant/Makefile b/package/wpa_supplicant/Makefile
index 0a72572886..1171ba00d3 100644
--- a/package/wpa_supplicant/Makefile
+++ b/package/wpa_supplicant/Makefile
@@ -31,13 +31,7 @@ define Package/wpa-supplicant/Description
endef
define Package/wpa-supplicant/config
- config WPA_SUPPLICANT_NO_TIMESTAMP_CHECK
- bool "Disable timestamp check"
- depends PACKAGE_wpa-supplicant
- default n
- help
- This disables the timestamp check for certificates in wpa_supplicant
- Useful for devices without RTC that cannot reliably get the real date/time
+ source "$(SOURCE)/Config.in"
endef