aboutsummaryrefslogtreecommitdiffstats
path: root/package/wlcompat
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-23 00:29:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-23 00:29:07 +0000
commit5a325930579db5f9175bea19459c845746801ae4 (patch)
tree8b63e203323c3c4ab05aa9bf0a9ec17f5dc87c91 /package/wlcompat
parent7bc567a0409f4d9aa9a4e12e9c56bc892b737da3 (diff)
downloadmaster-187ad058-5a325930579db5f9175bea19459c845746801ae4.tar.gz
master-187ad058-5a325930579db5f9175bea19459c845746801ae4.tar.bz2
master-187ad058-5a325930579db5f9175bea19459c845746801ae4.zip
replace lots of manual install commands with INSTALL_* variables
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5624 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/wlcompat')
-rw-r--r--package/wlcompat/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/wlcompat/Makefile b/package/wlcompat/Makefile
index 4a37294658..44acaee1f1 100644
--- a/package/wlcompat/Makefile
+++ b/package/wlcompat/Makefile
@@ -62,14 +62,14 @@ define Build/Compile
endef
define Package/kmod-wlcompat/install
- install -d -m0755 $(1)/lib/modules/$(LINUX_VERSION)
+ $(INSTALL_DIR) $(1)/lib/modules/$(LINUX_VERSION)
$(CP) $(PKG_BUILD_DIR)/wlcompat.o $(1)/lib/modules/$(LINUX_VERSION)/
- install -d -m0755 $(1)/etc/modules.d
+ $(INSTALL_DIR) $(1)/etc/modules.d
echo "wlcompat" > $(1)/etc/modules.d/30-wlcompat
endef
define Package/kmod-wlcompat-debug/install
- install -d -m0755 $(1)/lib/modules/$(LINUX_VERSION)
+ $(INSTALL_DIR) $(1)/lib/modules/$(LINUX_VERSION)
$(CP) $(PKG_BUILD_DIR)/wlcompat-debug.o $(1)/lib/modules/$(LINUX_VERSION)/
endef