aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2016-02-12 19:46:31 +0000
committerJo-Philipp Wich <jow@openwrt.org>2016-02-12 19:46:31 +0000
commitfb3f2e8958d82e2a02c58da5bfcc4466be2fd790 (patch)
tree1f501299944eecb168b4a5b1bc1b1c4d03553262 /package/utils
parentccfa204cabd5d2df38127e0bb4795994f278483f (diff)
downloadmaster-187ad058-fb3f2e8958d82e2a02c58da5bfcc4466be2fd790.tar.gz
master-187ad058-fb3f2e8958d82e2a02c58da5bfcc4466be2fd790.tar.bz2
master-187ad058-fb3f2e8958d82e2a02c58da5bfcc4466be2fd790.zip
busybox: fix broken default for FEATURE_IP_ROUTE_DIR (#21845)
Changeset r47775 introduced a wrong default value "n" for the ip applets config search path, breaking the handling of named routing tables and other objects having alias configurations. Fix the issue by providing a proper default value aligned with the value used by full iproute2. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48716 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/utils')
-rw-r--r--package/utils/busybox/Config-defaults.in2
-rw-r--r--package/utils/busybox/Makefile4
2 files changed, 3 insertions, 3 deletions
diff --git a/package/utils/busybox/Config-defaults.in b/package/utils/busybox/Config-defaults.in
index 3df4cda4fb..ee42fa12f0 100644
--- a/package/utils/busybox/Config-defaults.in
+++ b/package/utils/busybox/Config-defaults.in
@@ -2172,7 +2172,7 @@ config BUSYBOX_DEFAULT_FEATURE_IP_ROUTE
default y
config BUSYBOX_DEFAULT_FEATURE_IP_ROUTE_DIR
string
- default "n"
+ default "/etc/iproute2"
config BUSYBOX_DEFAULT_FEATURE_IP_TUNNEL
bool
default n
diff --git a/package/utils/busybox/Makefile b/package/utils/busybox/Makefile
index 95e785bfe6..6a55d5687c 100644
--- a/package/utils/busybox/Makefile
+++ b/package/utils/busybox/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2015 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=busybox
PKG_VERSION:=1.24.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_FLAGS:=essential
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2