aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-28 22:42:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-28 22:42:25 +0000
commit2654e74c19a4ebd17a45b5200b3a556a9dd9201e (patch)
tree59f64da72b002e40fd12f46f1f1dafc0c70a7d93 /package/utils
parent447709d50ff1c2054eb26c1123a529acb42883e0 (diff)
downloadmaster-187ad058-2654e74c19a4ebd17a45b5200b3a556a9dd9201e.tar.gz
master-187ad058-2654e74c19a4ebd17a45b5200b3a556a9dd9201e.tar.bz2
master-187ad058-2654e74c19a4ebd17a45b5200b3a556a9dd9201e.zip
busybox: disable timestamp in version
Signed-off-by: Alexander Couzens <lynxis@fe80.eu> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48539 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/utils')
-rw-r--r--package/utils/busybox/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/utils/busybox/Makefile b/package/utils/busybox/Makefile
index 5ca4363f1d..95e785bfe6 100644
--- a/package/utils/busybox/Makefile
+++ b/package/utils/busybox/Makefile
@@ -57,6 +57,9 @@ endef
BUSYBOX_SYM=$(if $(CONFIG_BUSYBOX_CUSTOM),CONFIG,DEFAULT)
+# don't create a version string containing the actual timestamp
+export KCONFIG_NOTIMESTAMP=1
+
define Build/Configure
rm -f $(PKG_BUILD_DIR)/.configured*
grep 'CONFIG_BUSYBOX_$(BUSYBOX_SYM)' $(TOPDIR)/.config | sed -e "s,\\(# \)\\?CONFIG_BUSYBOX_$(BUSYBOX_SYM)_\\(.*\\),\\1CONFIG_\\2,g" > $(PKG_BUILD_DIR)/.config