aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/util-linux
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-09-11 16:35:02 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-09-11 16:35:02 +0000
commitcc1026770b1e0a779fb6c360029b03627e62af63 (patch)
tree8fa0f59ca7256437f2034c3997a748eca3b7e261 /package/utils/util-linux
parenta983cff81bf0e8d65fd9167346d3b7c7364e224a (diff)
downloadmaster-187ad058-cc1026770b1e0a779fb6c360029b03627e62af63.tar.gz
master-187ad058-cc1026770b1e0a779fb6c360029b03627e62af63.tar.bz2
master-187ad058-cc1026770b1e0a779fb6c360029b03627e62af63.zip
util-linux: add prlimit command.
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46866 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/utils/util-linux')
-rw-r--r--package/utils/util-linux/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/utils/util-linux/Makefile b/package/utils/util-linux/Makefile
index cf80012879..f037e6a6b5 100644
--- a/package/utils/util-linux/Makefile
+++ b/package/utils/util-linux/Makefile
@@ -303,6 +303,17 @@ define Package/namei/description
files, directories, and so forth)
endef
+define Package/prlimit
+$(call Package/util-linux/Default)
+ TITLE:=get and set process resource limits
+ DEPENDS:= +libsmartcols
+endef
+
+define Package/prlimit/description
+ Given a process id and one or more resources, prlimit tries to retrieve
+ and/or modify the limits.
+endef
+
define Package/rename
$(call Package/util-linux/Default)
TITLE:=rename files
@@ -534,6 +545,11 @@ define Package/namei/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/namei $(1)/usr/bin/
endef
+define Package/prlimit/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/.libs/prlimit $(1)/usr/bin/
+endef
+
define Package/rename/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/rename $(1)/usr/bin/
@@ -614,6 +630,7 @@ $(eval $(call BuildPackage,lsblk))
$(eval $(call BuildPackage,mcookie))
$(eval $(call BuildPackage,mount-utils))
$(eval $(call BuildPackage,namei))
+$(eval $(call BuildPackage,prlimit))
$(eval $(call BuildPackage,rename))
$(eval $(call BuildPackage,partx-utils))
$(eval $(call BuildPackage,script-utils))