aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/util-linux
diff options
context:
space:
mode:
authorWaldemar Brodkorb <wbx@uclibc-ng.org>2016-07-07 14:54:28 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-07-07 14:54:28 +0200
commit8852da8090a016dc75b3ce9019c551015753034d (patch)
treeec2c296a9228683b6f5de5b491bc8e2c3376ed57 /package/utils/util-linux
parente6286ceebc1b4410eb9fa04f59712011364cbd4a (diff)
downloadmaster-187ad058-8852da8090a016dc75b3ce9019c551015753034d.tar.gz
master-187ad058-8852da8090a016dc75b3ce9019c551015753034d.tar.bz2
master-187ad058-8852da8090a016dc75b3ce9019c551015753034d.zip
util-linux: fix scanf fallback detection for uClibc-ng
uClibc-ng pretends to be GNU libc 2.2 and then a fallback scanf check is tried, so that libmount is disabled afterwards. Add a fix already suggested upstream. Add librt dependency required for other apps, too. Signed-off-by: Waldemar Brodkorb <wbx@uclibc-ng.org>
Diffstat (limited to 'package/utils/util-linux')
-rw-r--r--package/utils/util-linux/Makefile2
-rw-r--r--package/utils/util-linux/patches/0001-fix-uClibc-ng-scanf-check.patch34
2 files changed, 35 insertions, 1 deletions
diff --git a/package/utils/util-linux/Makefile b/package/utils/util-linux/Makefile
index c128b487e5..d5c08cc5bb 100644
--- a/package/utils/util-linux/Makefile
+++ b/package/utils/util-linux/Makefile
@@ -32,6 +32,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/util-linux/Default
SECTION:=utils
CATEGORY:=Utilities
+ DEPENDS:= +librt
URL:=http://www.kernel.org/pub/linux/utils/util-linux/
endef
@@ -202,7 +203,6 @@ endef
define Package/dmesg
$(call Package/util-linux/Default)
TITLE:=print or control the kernel ring buffer
- DEPENDS:= +librt
endef
define Package/dmesg/description
diff --git a/package/utils/util-linux/patches/0001-fix-uClibc-ng-scanf-check.patch b/package/utils/util-linux/patches/0001-fix-uClibc-ng-scanf-check.patch
new file mode 100644
index 0000000000..2da95f6cdb
--- /dev/null
+++ b/package/utils/util-linux/patches/0001-fix-uClibc-ng-scanf-check.patch
@@ -0,0 +1,34 @@
+From 180c908e2e80552b19bf3552667fc197d6edf7b3 Mon Sep 17 00:00:00 2001
+From: Waldemar Brodkorb <wbx@uclibc-ng.org>
+Date: Fri, 3 Jun 2016 04:13:08 +0200
+Subject: [PATCH] fix uClibc-ng scanf check
+
+uClibc-ng tries to be compatible with GNU libc and defines
+__GLIBC__ and pretend to be version 2.2.
+We once changed it to 2.10, but then some hard to fix problems
+in different software packages (gcc) occured.
+It would be better if we disable the special GNU libc checks
+for uClibc-ng here. uClibc-ng implements the required scanf
+functionality.
+
+Signed-off-by: Waldemar Brodkorb <wbx@uclibc-ng.org>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index f36b18c..4661c0d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -581,7 +581,7 @@ AC_CACHE_VAL([scanf_cv_alloc_modifier],
+ #include <stdio.h>
+ #include <unistd.h>
+
+- #ifdef __GLIBC__
++ #if defined(__GLIBC__) && !defined(__UCLIBC__)
+
+ #if !(__GLIBC_PREREQ(2, 7))
+ #error %m is not available
+--
+2.1.4
+