aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/util-linux/patches/002-mkostemp.patch
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-11-30 22:11:09 +0000
committerLuka Perkov <luka@openwrt.org>2014-11-30 22:11:09 +0000
commite24ab7ea3203dade28029f6f9569a3ae72c4bbf2 (patch)
treec4ddd1a9011fb900178fba902010e3337bc04122 /package/utils/util-linux/patches/002-mkostemp.patch
parentd6ec05aec4810caac3f067b0fa4d358af353987d (diff)
downloadmaster-187ad058-e24ab7ea3203dade28029f6f9569a3ae72c4bbf2.tar.gz
master-187ad058-e24ab7ea3203dade28029f6f9569a3ae72c4bbf2.tar.bz2
master-187ad058-e24ab7ea3203dade28029f6f9569a3ae72c4bbf2.zip
util-linux: update to 2.25.2
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43443 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/utils/util-linux/patches/002-mkostemp.patch')
-rw-r--r--package/utils/util-linux/patches/002-mkostemp.patch27
1 files changed, 4 insertions, 23 deletions
diff --git a/package/utils/util-linux/patches/002-mkostemp.patch b/package/utils/util-linux/patches/002-mkostemp.patch
index 0ad84722d2..0281842300 100644
--- a/package/utils/util-linux/patches/002-mkostemp.patch
+++ b/package/utils/util-linux/patches/002-mkostemp.patch
@@ -16,20 +16,21 @@ Patches revert upstream changes in order to support older
machines.
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
+---
--- a/configure.ac
+++ b/configure.ac
-@@ -299,6 +299,7 @@ AC_CHECK_FUNCS([ \
+@@ -315,6 +315,7 @@ AC_CHECK_FUNCS([ \
llseek \
lseek64 \
mempcpy \
+ mkostemp \
nanosleep \
+ open_memstream \
personality \
- posix_fadvise \
--- a/include/c.h
+++ b/include/c.h
-@@ -236,6 +236,13 @@ static inline int dirfd(DIR *d)
+@@ -233,6 +233,13 @@ static inline int dirfd(DIR *d)
#endif
/*
@@ -43,23 +44,3 @@ Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
* MAXHOSTNAMELEN replacement
*/
static inline size_t get_hostname_max(void)
---- a/lib/randutils.c
-+++ b/lib/randutils.c
-@@ -16,6 +16,7 @@
- #include <sys/syscall.h>
-
- #include "randutils.h"
-+#include "c.h"
-
- #ifdef HAVE_TLS
- #define THREAD_LOCAL static __thread
---- a/lib/wholedisk.c
-+++ b/lib/wholedisk.c
-@@ -10,6 +10,7 @@
-
- #include "blkdev.h"
- #include "wholedisk.h"
-+#include "c.h"
-
- int is_whole_disk_fd(int fd, const char *name)
- {