aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/ugps
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2015-04-02 14:53:00 +0000
committerNicolas Thill <nico@openwrt.org>2015-04-02 14:53:00 +0000
commitfe74dfa5fdb7f92b7efa6506c109f6a9a0124af4 (patch)
treef928574430f8607f27e84df69e25d8bd77ce5192 /package/utils/ugps
parent9a8824c9932b7a77f9eeb6b4759e14f2b7a258fd (diff)
downloadmaster-187ad058-fe74dfa5fdb7f92b7efa6506c109f6a9a0124af4.tar.gz
master-187ad058-fe74dfa5fdb7f92b7efa6506c109f6a9a0124af4.tar.bz2
master-187ad058-fe74dfa5fdb7f92b7efa6506c109f6a9a0124af4.zip
ugps: add conffiles section, fix config file perms
Signed-off-by: Nicolas Thill <nico@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45240 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/utils/ugps')
-rw-r--r--package/utils/ugps/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/utils/ugps/Makefile b/package/utils/ugps/Makefile
index 3662125c3a..b724f6189d 100644
--- a/package/utils/ugps/Makefile
+++ b/package/utils/ugps/Makefile
@@ -36,11 +36,15 @@ ifneq ($(CONFIG_USE_GLIBC),)
TARGET_CFLAGS += -D_DEFAULT_SOURCE
endif
+define Package/ugps/conffiles
+/etc/config/gps
+endef
+
define Package/ugps/install
$(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/init.d $(1)/etc/config
$(INSTALL_BIN) $(PKG_BUILD_DIR)/ugps $(1)/usr/sbin/
$(INSTALL_BIN) ./files/ugps.init $(1)/etc/init.d/ugps
- $(INSTALL_BIN) ./files/gps.config $(1)/etc/config/gps
+ $(INSTALL_CONF) ./files/gps.config $(1)/etc/config/gps
endef
$(eval $(call BuildPackage,ugps))