aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/spidev_test/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-06-21 16:54:37 +0000
committerJohn Crispin <blogic@openwrt.org>2013-06-21 16:54:37 +0000
commitf1b4824c865b228039d84b2605b2e7e4f34cddeb (patch)
tree37c9cbe251e4fb790aaa72e862c35822be30b491 /package/utils/spidev_test/Makefile
parentd2642de7494bba312bbb22cfeb3ad77130a10047 (diff)
downloadmaster-187ad058-f1b4824c865b228039d84b2605b2e7e4f34cddeb.tar.gz
master-187ad058-f1b4824c865b228039d84b2605b2e7e4f34cddeb.tar.bz2
master-187ad058-f1b4824c865b228039d84b2605b2e7e4f34cddeb.zip
packages: clean up the package folder
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37007 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/utils/spidev_test/Makefile')
-rw-r--r--package/utils/spidev_test/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/package/utils/spidev_test/Makefile b/package/utils/spidev_test/Makefile
new file mode 100644
index 0000000000..807039a1f5
--- /dev/null
+++ b/package/utils/spidev_test/Makefile
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=spidev-test
+PKG_RELEASE:=$(LINUX_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/spidev-test
+ SECTION:=utils
+ CATEGORY:=Utilities
+ DEPENDS:=+kmod-spi-dev
+ TITLE:=SPI testing utility
+ VERSION:=$(LINUX_VERSION)-$(PKG_RELEASE)
+ URL:=http://www.kernel.org
+ MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+endef
+
+define Package/spidev-test/description
+ SPI testing utility.
+endef
+
+define Build/Prepare
+endef
+
+define Build/Compile
+ $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/spidev_test \
+ $(LINUX_DIR)/Documentation/spi/spidev_test.c
+endef
+
+define Package/spidev-test/install
+ $(INSTALL_DIR) $(1)/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/spidev_test $(1)/sbin/
+endef
+
+$(eval $(call BuildPackage,spidev-test))