aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/px5g
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-01-25 23:33:49 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-01-25 23:33:49 +0000
commita5fe570c0296de3721efffa772824cdda11c8064 (patch)
treee5b858d7efad6ce2280779aea1ce7e83aeab16bc /package/utils/px5g
parentb51201036007d69f616b76f7b9c8a2254c3fa57d (diff)
downloadmaster-187ad058-a5fe570c0296de3721efffa772824cdda11c8064.tar.gz
master-187ad058-a5fe570c0296de3721efffa772824cdda11c8064.tar.bz2
master-187ad058-a5fe570c0296de3721efffa772824cdda11c8064.zip
fix subject in generated certificates
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44149 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/utils/px5g')
-rw-r--r--package/utils/px5g/Makefile7
-rw-r--r--package/utils/px5g/px5g.c2
2 files changed, 4 insertions, 5 deletions
diff --git a/package/utils/px5g/Makefile b/package/utils/px5g/Makefile
index df2a170d84..8677a8b174 100644
--- a/package/utils/px5g/Makefile
+++ b/package/utils/px5g/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2010-2014 Jo-Philipp Wich <xm@subsignal.org>
+# Copyright (C) 2010-2015 Jo-Philipp Wich <jow@openwrt.org>
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,9 +8,8 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=px5g
-PKG_RELEASE:=2
+PKG_RELEASE:=3
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)
PKG_USE_MIPS16:=0
include $(INCLUDE_DIR)/package.mk
@@ -19,7 +18,7 @@ define Package/px5g
SECTION:=utils
CATEGORY:=Utilities
TITLE:=X.509 certificate generator (using PolarSSL)
- MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
+ MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
DEPENDS:=+libpolarssl
endef
diff --git a/package/utils/px5g/px5g.c b/package/utils/px5g/px5g.c
index 633aa51361..eec8fd3f51 100644
--- a/package/utils/px5g/px5g.c
+++ b/package/utils/px5g/px5g.c
@@ -188,7 +188,7 @@ int selfsigned(char **arg)
}
memcpy(newc, oldc, delim - oldc);
newc += delim - oldc;
- *newc++ = ';';
+ *newc++ = ',';
oldc = delim + 1;
} while(*delim);
arg++;