aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/jsonpath/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-06-18 10:10:30 +0000
committerJo-Philipp Wich <jow@openwrt.org>2014-06-18 10:10:30 +0000
commita586bc77e71b57e59b054e79838b20a396348df6 (patch)
tree6f88b18ab3d8c04050519cb65b218155ab39218f /package/utils/jsonpath/Makefile
parentd8e56de762bc32636f9e00ed586e2aa1aa90e36d (diff)
downloadmaster-187ad058-a586bc77e71b57e59b054e79838b20a396348df6.tar.gz
master-187ad058-a586bc77e71b57e59b054e79838b20a396348df6.tar.bz2
master-187ad058-a586bc77e71b57e59b054e79838b20a396348df6.zip
jsonpath: rename to jsonfilter and rewrite from flex/bison to lemon
This commit renames the jsonpath binary to jsonfilter to avoid clashing with a Python extension of the same name. The utility itself has been rewritten to use SQLite3's lemon parser generator instead of a flex/bison combination which results in a much smaller binary. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41258 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/utils/jsonpath/Makefile')
-rw-r--r--package/utils/jsonpath/Makefile31
1 files changed, 0 insertions, 31 deletions
diff --git a/package/utils/jsonpath/Makefile b/package/utils/jsonpath/Makefile
deleted file mode 100644
index be64fed856..0000000000
--- a/package/utils/jsonpath/Makefile
+++ /dev/null
@@ -1,31 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=jsonpath
-PKG_VERSION:=2014-01-08
-PKG_RELEASE=$(PKG_SOURCE_VERSION)
-
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=http://git.openwrt.org/project/jsonpath.git
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=f1e3aeb2526ea28db34c7bc714277c1dff26e5fc
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
-CMAKE_INSTALL:=1
-
-PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
-
-include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/cmake.mk
-
-define Package/jsonpath
- SECTION:=base
- CATEGORY:=Base system
- DEPENDS:=+libubox +libjson-c
- TITLE:=OpenWrt JSON query utility
-endef
-
-define Package/jsonpath/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/jsonpath $(1)/usr/bin/
-endef
-
-$(eval $(call BuildPackage,jsonpath))