aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/fuse
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2015-05-24 17:56:26 +0000
committerNicolas Thill <nico@openwrt.org>2015-05-24 17:56:26 +0000
commit40a946028d218c6e848e995451e1ce600abbaf19 (patch)
treea5192b51067a12b3cfc458c8853982f83e4a436b /package/utils/fuse
parentcbf4417ef7d3947cdc7026ff4835d0435b5da4b5 (diff)
downloadmaster-187ad058-40a946028d218c6e848e995451e1ce600abbaf19.tar.gz
master-187ad058-40a946028d218c6e848e995451e1ce600abbaf19.tar.bz2
master-187ad058-40a946028d218c6e848e995451e1ce600abbaf19.zip
fuse: fix exec environment for mount and umount
* add upstream patch (CVE-2015-3202) * refresh patches * bump release number Signed-off-by: Nicolas Thill <nico@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45744 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/utils/fuse')
-rw-r--r--package/utils/fuse/Makefile4
-rw-r--r--package/utils/fuse/patches/001-fix_exec_environment_for_mount_and_umount.patch59
-rw-r--r--package/utils/fuse/patches/200-backport_arm64_fuse_kernel_h_clean_includes.patch6
3 files changed, 62 insertions, 7 deletions
diff --git a/package/utils/fuse/Makefile b/package/utils/fuse/Makefile
index 43f1ef4dd7..787a66e3ca 100644
--- a/package/utils/fuse/Makefile
+++ b/package/utils/fuse/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2014 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=fuse
PKG_VERSION:=2.9.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
diff --git a/package/utils/fuse/patches/001-fix_exec_environment_for_mount_and_umount.patch b/package/utils/fuse/patches/001-fix_exec_environment_for_mount_and_umount.patch
new file mode 100644
index 0000000000..392bb5e2a8
--- /dev/null
+++ b/package/utils/fuse/patches/001-fix_exec_environment_for_mount_and_umount.patch
@@ -0,0 +1,59 @@
+From cfe13b7a217075ae741c018da50cd600e5330de2 Mon Sep 17 00:00:00 2001
+From: Miklos Szeredi <mszeredi@suse.cz>
+Date: Fri, 22 May 2015 10:58:43 +0200
+Subject: [PATCH] libfuse: fix exec environment for mount and umount
+
+Found by Tavis Ormandy (CVE-2015-3202).
+---
+--- a/lib/mount_util.c
++++ b/lib/mount_util.c
+@@ -95,10 +95,12 @@ static int add_mount(const char *prognam
+ goto out_restore;
+ }
+ if (res == 0) {
++ char *env = NULL;
++
+ sigprocmask(SIG_SETMASK, &oldmask, NULL);
+ setuid(geteuid());
+- execl("/bin/mount", "/bin/mount", "--no-canonicalize", "-i",
+- "-f", "-t", type, "-o", opts, fsname, mnt, NULL);
++ execle("/bin/mount", "/bin/mount", "--no-canonicalize", "-i",
++ "-f", "-t", type, "-o", opts, fsname, mnt, NULL, &env);
+ fprintf(stderr, "%s: failed to execute /bin/mount: %s\n",
+ progname, strerror(errno));
+ exit(1);
+@@ -146,10 +148,17 @@ static int exec_umount(const char *progn
+ goto out_restore;
+ }
+ if (res == 0) {
++ char *env = NULL;
++
+ sigprocmask(SIG_SETMASK, &oldmask, NULL);
+ setuid(geteuid());
+- execl("/bin/umount", "/bin/umount", "-i", rel_mnt,
+- lazy ? "-l" : NULL, NULL);
++ if (lazy) {
++ execle("/bin/umount", "/bin/umount", "-i", rel_mnt,
++ "-l", NULL, &env);
++ } else {
++ execle("/bin/umount", "/bin/umount", "-i", rel_mnt,
++ NULL, &env);
++ }
+ fprintf(stderr, "%s: failed to execute /bin/umount: %s\n",
+ progname, strerror(errno));
+ exit(1);
+@@ -205,10 +214,12 @@ static int remove_mount(const char *prog
+ goto out_restore;
+ }
+ if (res == 0) {
++ char *env = NULL;
++
+ sigprocmask(SIG_SETMASK, &oldmask, NULL);
+ setuid(geteuid());
+- execl("/bin/umount", "/bin/umount", "--no-canonicalize", "-i",
+- "--fake", mnt, NULL);
++ execle("/bin/umount", "/bin/umount", "--no-canonicalize", "-i",
++ "--fake", mnt, NULL, &env);
+ fprintf(stderr, "%s: failed to execute /bin/umount: %s\n",
+ progname, strerror(errno));
+ exit(1);
diff --git a/package/utils/fuse/patches/200-backport_arm64_fuse_kernel_h_clean_includes.patch b/package/utils/fuse/patches/200-backport_arm64_fuse_kernel_h_clean_includes.patch
index 8436224e96..d45da84cca 100644
--- a/package/utils/fuse/patches/200-backport_arm64_fuse_kernel_h_clean_includes.patch
+++ b/package/utils/fuse/patches/200-backport_arm64_fuse_kernel_h_clean_includes.patch
@@ -8,11 +8,9 @@ using <stdint.h> types.
---
(limited to 'include/fuse_kernel.h')
-diff --git a/include/fuse_kernel.h b/include/fuse_kernel.h
-index 501450c..df8e9b9 100644
--- a/include/fuse_kernel.h
+++ b/include/fuse_kernel.h
-@@ -91,12 +91,16 @@
+@@ -88,12 +88,16 @@
#ifndef _LINUX_FUSE_H
#define _LINUX_FUSE_H
@@ -30,5 +28,3 @@ index 501450c..df8e9b9 100644
/*
* Version negotiation:
---
-cgit v0.9.0.3-67-gacbf