aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/bzip2
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-12-19 11:28:49 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-12-19 11:28:49 +0000
commita27fc4573ea466f779fadd35507f127af9bd385b (patch)
treeff3abe7c285260695cf5e2302eca0036fd77a252 /package/utils/bzip2
parentaedfbb331b83eea6f0f8bad4b980c75bbbda5615 (diff)
downloadmaster-187ad058-a27fc4573ea466f779fadd35507f127af9bd385b.tar.gz
master-187ad058-a27fc4573ea466f779fadd35507f127af9bd385b.tar.bz2
master-187ad058-a27fc4573ea466f779fadd35507f127af9bd385b.zip
Revert "bzip2: extend/fix the Host/Install rule to install libbz2.so files"
This reverts r47245. Linking to shared libraries under $STAGING_DIR_HOST{,/usr}/lib is harmful, as these directories aren't added to LD_LIBRARY_PATH (see r47103 for an explanation why LD_LIBRARY_PATH is not used). Revert to static linking; in particular, this fixes the build of the python bz2 module on OpenSUSE and Fedora (which in turn broke the build of nodejs). Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47950 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/utils/bzip2')
-rw-r--r--package/utils/bzip2/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/package/utils/bzip2/Makefile b/package/utils/bzip2/Makefile
index ba47cfb7e3..4ad9684217 100644
--- a/package/utils/bzip2/Makefile
+++ b/package/utils/bzip2/Makefile
@@ -97,10 +97,8 @@ HOST_CONFIGURE_ARGS+= \
--prefix=$(STAGING_DIR_HOST)
define Host/Install
- $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/ $(STAGING_DIR_HOST)/usr/lib
+ $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/
$(MAKE) -C $(HOST_BUILD_DIR) PREFIX=$(STAGING_DIR_HOST)/usr/ install
- $(CP) $(HOST_BUILD_DIR)/libbz2.so* $(STAGING_DIR_HOST)/usr/lib/
- $(CP) $(HOST_BUILD_DIR)/libbz2.so.1.0 $(STAGING_DIR_HOST)/usr/lib/libbz2.so
endef
$(eval $(call HostBuild))