aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/bzip2
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2015-10-22 13:24:35 +0000
committerSteven Barth <steven@midlink.org>2015-10-22 13:24:35 +0000
commit2d78997f58fff41324cc6157e11d070ffcb8bee1 (patch)
tree53db7c760beb4950a885649cbace67002740439d /package/utils/bzip2
parente9336b3c83ff013e028f7c464c8527c626b3ad09 (diff)
downloadmaster-187ad058-2d78997f58fff41324cc6157e11d070ffcb8bee1.tar.gz
master-187ad058-2d78997f58fff41324cc6157e11d070ffcb8bee1.tar.bz2
master-187ad058-2d78997f58fff41324cc6157e11d070ffcb8bee1.zip
bzip2: extend/fix the Host/Install rule to install libbz2.so files
It looks like the bzip2 package does not install any shared libs and has no build rules to install any shared libs. So, for the host build we're installing the libbz2 shared libs manually so that other modules can link against them. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47245 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/utils/bzip2')
-rw-r--r--package/utils/bzip2/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/utils/bzip2/Makefile b/package/utils/bzip2/Makefile
index e1c7b97ffc..ba47cfb7e3 100644
--- a/package/utils/bzip2/Makefile
+++ b/package/utils/bzip2/Makefile
@@ -97,9 +97,10 @@ HOST_CONFIGURE_ARGS+= \
--prefix=$(STAGING_DIR_HOST)
define Host/Install
- $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/
+ $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/ $(STAGING_DIR_HOST)/usr/lib
$(MAKE) -C $(HOST_BUILD_DIR) PREFIX=$(STAGING_DIR_HOST)/usr/ install
-# $(INSTALL_BIN) $(HOST_BUILD_DIR)/Parser/pgen $(STAGING_DIR_HOST)/bin/pgen2
+ $(CP) $(HOST_BUILD_DIR)/libbz2.so* $(STAGING_DIR_HOST)/usr/lib/
+ $(CP) $(HOST_BUILD_DIR)/libbz2.so.1.0 $(STAGING_DIR_HOST)/usr/lib/libbz2.so
endef
$(eval $(call HostBuild))