aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/busybox
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-03-13 08:38:56 +0000
committerJohn Crispin <blogic@openwrt.org>2015-03-13 08:38:56 +0000
commitc5c4f4131b54b323cc93e694cf417e12d94acea2 (patch)
tree6b0ce1ebac8ac4b8b81458ffd3cceb82a2e6a255 /package/utils/busybox
parent451e7b98b4616e8354cf326760d879e154ddda0d (diff)
downloadmaster-187ad058-c5c4f4131b54b323cc93e694cf417e12d94acea2.tar.gz
master-187ad058-c5c4f4131b54b323cc93e694cf417e12d94acea2.tar.bz2
master-187ad058-c5c4f4131b54b323cc93e694cf417e12d94acea2.zip
BusyBox: Netcat 1.10 compatibility require server option
Netcat 1.10 compatibility require server options 1.10 compatibility without server option produce error "NO OPT l!" and completely not function Signed-off-by: Christian Schoenebeck <christian.schoenebeck@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44746 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/utils/busybox')
-rw-r--r--package/utils/busybox/Makefile6
-rw-r--r--package/utils/busybox/config/networking/Config.in1
2 files changed, 4 insertions, 3 deletions
diff --git a/package/utils/busybox/Makefile b/package/utils/busybox/Makefile
index fcfdc8bbef..7421c0a5e7 100644
--- a/package/utils/busybox/Makefile
+++ b/package/utils/busybox/Makefile
@@ -1,5 +1,5 @@
-#
-# Copyright (C) 2006-2014 OpenWrt.org
+#
+# Copyright (C) 2006-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=busybox
PKG_VERSION:=1.22.1
-PKG_RELEASE:=5
+PKG_RELEASE:=6
PKG_FLAGS:=essential
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
diff --git a/package/utils/busybox/config/networking/Config.in b/package/utils/busybox/config/networking/Config.in
index 80dd42abd0..52e38a3f00 100644
--- a/package/utils/busybox/config/networking/Config.in
+++ b/package/utils/busybox/config/networking/Config.in
@@ -67,6 +67,7 @@ config BUSYBOX_CONFIG_NC_110_COMPAT
bool "Netcat 1.10 compatibility (+2.5k)"
default BUSYBOX_DEFAULT_NC_110_COMPAT # off specially for Rob
depends on BUSYBOX_CONFIG_NC
+ select BUSYBOX_CONFIG_NC_SERVER
help
This option makes nc closely follow original nc-1.10.
The code is about 2.5k bigger. It enables