aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/busybox/patches/110-no_static_libgcc.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-05-25 17:42:09 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-05-25 17:42:09 +0000
commit361e70a4855e69d2e5d41f85ba3896eaa37bcfa6 (patch)
tree57a5c3d39799a3bb41b11961df2bc18bd457355e /package/utils/busybox/patches/110-no_static_libgcc.patch
parenteca9f275a1cfc875a98a5e790b04875c159a14ee (diff)
downloadmaster-187ad058-361e70a4855e69d2e5d41f85ba3896eaa37bcfa6.tar.gz
master-187ad058-361e70a4855e69d2e5d41f85ba3896eaa37bcfa6.tar.bz2
master-187ad058-361e70a4855e69d2e5d41f85ba3896eaa37bcfa6.zip
busybox: update to 1.22.1
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40852 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/utils/busybox/patches/110-no_static_libgcc.patch')
-rw-r--r--package/utils/busybox/patches/110-no_static_libgcc.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/utils/busybox/patches/110-no_static_libgcc.patch b/package/utils/busybox/patches/110-no_static_libgcc.patch
new file mode 100644
index 0000000000..2148a09e00
--- /dev/null
+++ b/package/utils/busybox/patches/110-no_static_libgcc.patch
@@ -0,0 +1,11 @@
+--- a/Makefile.flags
++++ b/Makefile.flags
+@@ -51,7 +51,7 @@ CFLAGS += $(call cc-option,-fno-builtin-
+ # -fno-guess-branch-probability: prohibit pseudo-random guessing
+ # of branch probabilities (hopefully makes bloatcheck more stable):
+ CFLAGS += $(call cc-option,-fno-guess-branch-probability,)
+-CFLAGS += $(call cc-option,-funsigned-char -static-libgcc,)
++CFLAGS += $(call cc-option,-funsigned-char,)
+ CFLAGS += $(call cc-option,-falign-functions=1 -falign-jumps=1 -falign-labels=1 -falign-loops=1,)
+ # Defeat .eh_frame bloat (gcc 4.6.3 x86-32 defconfig: 20% smaller busybox binary):
+ CFLAGS += $(call cc-option,-fno-unwind-tables,)