aboutsummaryrefslogtreecommitdiffstats
path: root/package/ubus/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-12-22 18:56:09 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-12-22 18:56:09 +0000
commitd8c3a7ef1946f46062bacd0f657882ed5ce1add7 (patch)
treeac5cd21cba329b712ffbbdfb1b5cc2da64e8757d /package/ubus/Makefile
parent56e6c5df09c5e58a7546d88e2927a27e6d7803d6 (diff)
downloadmaster-187ad058-d8c3a7ef1946f46062bacd0f657882ed5ce1add7.tar.gz
master-187ad058-d8c3a7ef1946f46062bacd0f657882ed5ce1add7.tar.bz2
master-187ad058-d8c3a7ef1946f46062bacd0f657882ed5ce1add7.zip
base-files: add basic procd integration, let procd start (and restart) ubus instead of having an ubus init script
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34866 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ubus/Makefile')
-rw-r--r--package/ubus/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/ubus/Makefile b/package/ubus/Makefile
index 617c76749b..782079d775 100644
--- a/package/ubus/Makefile
+++ b/package/ubus/Makefile
@@ -63,8 +63,7 @@ define Package/ubus/install
endef
define Package/ubusd/install
- $(INSTALL_DIR) $(1)/sbin $(1)/etc/init.d
- $(INSTALL_BIN) ./files/ubus.init $(1)/etc/init.d/ubus
+ $(INSTALL_DIR) $(1)/sbin
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/ubusd $(1)/sbin/
endef