aboutsummaryrefslogtreecommitdiffstats
path: root/package/uboot-lantiq
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2011-09-26 09:00:11 +0000
committerJohn Crispin <blogic@openwrt.org>2011-09-26 09:00:11 +0000
commit573a49afbe1007930b46e49eeb1b01659ef7c83e (patch)
tree3006fcbdc3eb30e25dc59ad2804151afa39c53fe /package/uboot-lantiq
parentcb8a262145c152831e1080ad0e1ed6dedb2f33a9 (diff)
downloadmaster-187ad058-573a49afbe1007930b46e49eeb1b01659ef7c83e.tar.gz
master-187ad058-573a49afbe1007930b46e49eeb1b01659ef7c83e.tar.bz2
master-187ad058-573a49afbe1007930b46e49eeb1b01659ef7c83e.zip
[uboot-lantiq]
* fixes brnboot image generation git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28307 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/uboot-lantiq')
-rw-r--r--package/uboot-lantiq/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/package/uboot-lantiq/Makefile b/package/uboot-lantiq/Makefile
index 015efcfe60..44a0eec8aa 100644
--- a/package/uboot-lantiq/Makefile
+++ b/package/uboot-lantiq/Makefile
@@ -119,15 +119,15 @@ endef
define Package/uboot-lantiq-$(BUILD_VARIANT)/install
mkdir -p $(1)
-ifneq ($(findstring ramboot,$(BUILD_VARIANT)),)
+ifneq ($(findstring flash,$(BUILD_VARIANT)),)
dd \
- if=$(PKG_BUILD_DIR)/$(BUILD_VARIANT)/u-boot.bin \
- of=$(1)/u-boot.bin \
+ if=$(PKG_BUILD_DIR)/$(BUILD_VARIANT)/u-boot-bootstrap.bin \
+ of=$(1)/u-boot-bootstrap.bin \
bs=64k conv=sync
else
dd \
- if=$(PKG_BUILD_DIR)/$(BUILD_VARIANT)/u-boot-bootstrap.bin \
- of=$(1)/u-boot-bootstrap.bin \
+ if=$(PKG_BUILD_DIR)/$(BUILD_VARIANT)/u-boot.bin \
+ of=$(1)/u-boot.bin \
bs=64k conv=sync
endif
ifneq ($(findstring ramboot,$(BUILD_VARIANT)),)