aboutsummaryrefslogtreecommitdiffstats
path: root/package/uboot-lantiq/patches/010-fix-mips-flags.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-03-28 22:40:32 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-03-28 22:40:32 +0000
commite4490cccdd3145a019940213cc06d87e6468bdb4 (patch)
treeaa64a4eb197b91873d662ebd1b617b1a32bb3cc1 /package/uboot-lantiq/patches/010-fix-mips-flags.patch
parentb4197c908d09b9bd00e01d8ac6514709f5dc193e (diff)
downloadmaster-187ad058-e4490cccdd3145a019940213cc06d87e6468bdb4.tar.gz
master-187ad058-e4490cccdd3145a019940213cc06d87e6468bdb4.tar.bz2
master-187ad058-e4490cccdd3145a019940213cc06d87e6468bdb4.zip
add uboot-lantiq (based on a patch contributed by Lantiq)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20561 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/uboot-lantiq/patches/010-fix-mips-flags.patch')
-rw-r--r--package/uboot-lantiq/patches/010-fix-mips-flags.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/package/uboot-lantiq/patches/010-fix-mips-flags.patch b/package/uboot-lantiq/patches/010-fix-mips-flags.patch
new file mode 100644
index 0000000000..4c706a7843
--- /dev/null
+++ b/package/uboot-lantiq/patches/010-fix-mips-flags.patch
@@ -0,0 +1,23 @@
+--- a/cpu/mips/config.mk
++++ b/cpu/mips/config.mk
+@@ -23,16 +23,18 @@
+ v=$(shell $(AS) --version | grep 'GNU assembler' | egrep -o '2\.[0-9\.]+' | cut -d. -f2)
+ MIPSFLAGS:=$(shell \
+ if [ "$v" -lt "14" ]; then \
+- echo "-mcpu=4kc"; \
++ echo "-mcpu=mips32"; \
+ else \
+- echo "-march=4kc -mtune=4kc"; \
++ echo "-mips32 -march=mips32 -mtune=mips32"; \
+ fi)
+
++ifndef ENDIANNESS
+ ifneq (,$(findstring 4KCle,$(CROSS_COMPILE)))
+ ENDIANNESS = -EL
+ else
+ ENDIANNESS = -EB
+ endif
++endif
+
+ MIPSFLAGS += $(ENDIANNESS)
+