aboutsummaryrefslogtreecommitdiffstats
path: root/package/uboot-lantiq/files/board/arcadyan/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2011-02-01 14:26:47 +0000
committerJohn Crispin <blogic@openwrt.org>2011-02-01 14:26:47 +0000
commit79a047aa996b7e7edb15c14e20d3889850b8039c (patch)
tree95b229d99fdd086985ad9f64914f1ab25e1eaa35 /package/uboot-lantiq/files/board/arcadyan/Makefile
parenta8d365bfb6bf0c7841538452592af986f0117a25 (diff)
downloadmaster-187ad058-79a047aa996b7e7edb15c14e20d3889850b8039c.tar.gz
master-187ad058-79a047aa996b7e7edb15c14e20d3889850b8039c.tar.bz2
master-187ad058-79a047aa996b7e7edb15c14e20d3889850b8039c.zip
[uboot-lantiq]
* rework the arcadyan sku support * adds a few new boards and switches git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25273 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/uboot-lantiq/files/board/arcadyan/Makefile')
-rw-r--r--package/uboot-lantiq/files/board/arcadyan/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/package/uboot-lantiq/files/board/arcadyan/Makefile b/package/uboot-lantiq/files/board/arcadyan/Makefile
new file mode 100644
index 0000000000..fb9027c655
--- /dev/null
+++ b/package/uboot-lantiq/files/board/arcadyan/Makefile
@@ -0,0 +1,46 @@
+#
+# (C) Copyright 2003-2006
+# Wolfgang Denk, DENX Software Engineering, wd@denx.de.
+#
+# See file CREDITS for list of people who contributed to this
+# project.
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2 of
+# the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston,
+# MA 02111-1307 USA
+#
+
+include $(TOPDIR)/config.mk
+
+LIB = $(obj)lib$(BOARD).a
+
+COBJS-y += board.o athrs26_phy.o
+
+SOBJS = lowlevel_init.o pmuenable.o
+
+SRCS := $(SOBJS:.o=.S) $(COBJS-y:.o=.c)
+OBJS := $(addprefix $(obj),$(COBJS-y))
+SOBJS := $(addprefix $(obj),$(SOBJS))
+
+$(LIB): $(obj).depend $(OBJS) $(SOBJS)
+ $(AR) $(ARFLAGS) $@ $(OBJS) $(SOBJS)
+
+#########################################################################
+
+# defines $(obj).depend target
+include $(SRCTREE)/rules.mk
+
+sinclude $(obj).depend
+
+#########################################################################