aboutsummaryrefslogtreecommitdiffstats
path: root/package/uboot-ifxmips/Makefile
diff options
context:
space:
mode:
authorOpenWrt Developers <openwrt-devel@openwrt.org>2008-11-19 17:40:05 +0000
committerOpenWrt Developers <openwrt-devel@openwrt.org>2008-11-19 17:40:05 +0000
commit7931f01fd898dab7002a601a92173b4ed2bd96dd (patch)
tree82989cd5ea141baf9cdc51d0578368e36cd15a67 /package/uboot-ifxmips/Makefile
parentb0f5f9729a310db2950ed84b8c7387cb7aa69494 (diff)
downloadmaster-187ad058-7931f01fd898dab7002a601a92173b4ed2bd96dd.tar.gz
master-187ad058-7931f01fd898dab7002a601a92173b4ed2bd96dd.tar.bz2
master-187ad058-7931f01fd898dab7002a601a92173b4ed2bd96dd.zip
[ifxmips] cleanup uboot package
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13291 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/uboot-ifxmips/Makefile')
-rw-r--r--package/uboot-ifxmips/Makefile27
1 files changed, 24 insertions, 3 deletions
diff --git a/package/uboot-ifxmips/Makefile b/package/uboot-ifxmips/Makefile
index 7895502b3b..10e9080e8b 100644
--- a/package/uboot-ifxmips/Makefile
+++ b/package/uboot-ifxmips/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=u-boot
PKG_VERSION:=1.1.5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -31,12 +31,33 @@ endef
define Build/Prepare
$(call Build/Prepare/Default)
- cp -r ./files/* $(PKG_BUILD_DIR)
+ cp -r $(CP_OPTS) ./files/* $(PKG_BUILD_DIR)
find $(PKG_BUILD_DIR) -name .svn | $(XARGS) rm -rf
endef
+UBOOT_CONFIG:=danube
+
+UBOOT_MAKE_OPTS:=\
+ CROSS_COMPILE=$(TARGET_CROSS) \
+ CROSS_COMPILE_UCLIBC=1 \
+ COMPRESS=lzma \
+ PLATFORM_CPU=mips32r2 \
+ UBOOT_RAM_TEXT_BASE=0xA0400000
+
+define Build/Configure
+ $(MAKE) -s -C $(PKG_BUILD_DIR) \
+ $(UBOOT_MAKE_OPTS) \
+ $(UBOOT_CONFIG)_config
+endef
+
define Build/Compile
- cd $(PKG_BUILD_DIR);chmod a+x build_danube.sh;./build_danube.sh
+ $(MAKE) -s -C $(PKG_BUILD_DIR) \
+ $(UBOOT_MAKE_OPTS) \
+ ifx_all
+ if [ `stat -c%s $(PKG_BUILD_DIR)/u-boot.ifx` -gt 65536 ] ;\
+ then \
+ echo "u-boot.ifx file has exceeded 64MB in size."; exit 1; \
+ fi
endef
define Package/uboot-ifxmips/install