aboutsummaryrefslogtreecommitdiffstats
path: root/package/templates.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-04-18 06:17:39 +0000
committerNicolas Thill <nico@openwrt.org>2005-04-18 06:17:39 +0000
commitbf3a2c7095311477eb5e242a4137f6d8556d83dc (patch)
tree764b682bf1ad6109ee850df24d7e0ef7092fb96b /package/templates.mk
parentc4b65c5f645e773849898f54a343acd278f61075 (diff)
downloadmaster-187ad058-bf3a2c7095311477eb5e242a4137f6d8556d83dc.tar.gz
master-187ad058-bf3a2c7095311477eb5e242a4137f6d8556d83dc.tar.bz2
master-187ad058-bf3a2c7095311477eb5e242a4137f6d8556d83dc.zip
Add common rules and templates Makefile includes for packages
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@662 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/templates.mk')
-rw-r--r--package/templates.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/package/templates.mk b/package/templates.mk
new file mode 100644
index 0000000000..c60d9ce01f
--- /dev/null
+++ b/package/templates.mk
@@ -0,0 +1,22 @@
+# $(call PKG_template,EXAMPLE,example,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+define PKG_template
+
+IPKG_$(1):=$(PACKAGE_DIR)/$(2)_$(3)_$(4).ipk
+IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg/$(2)
+INFO_$(1):=$(IPKG_STATE_DIR)/info/$(2).list
+
+PKG_FILES += $$(IPKG_$(1))
+ifneq ($(BR2_PACKAGE_$(1)),)
+COMPILE_TARGETS += $$(IPKG_$(1))
+endif
+ifeq ($(BR2_PACKAGE_$(1)),y)
+INSTALL_TARGETS += $$(INFO_$(1))
+endif
+
+$$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.prepared
+ $(SCRIPT_DIR)/make-ipkg-dir.sh $$(IDIR_$(1)) ./ipkg/$(2).control $(3) $(4)
+
+$$(INFO_$(1)): $$(IPKG_$(1))
+ $(IPKG) install $$(IPKG_$(1))
+
+endef