aboutsummaryrefslogtreecommitdiffstats
path: root/package/system
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-09-28 13:12:42 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-09-28 13:12:42 +0000
commit96216936f678fabdde919824d6a0212bbc8bc099 (patch)
treeeade5f0e002f8ffe422176489bb6529d8f0cb7b6 /package/system
parent4dd787c062a67afbe4588daa065d7c2bb2ac3bfd (diff)
downloadmaster-187ad058-96216936f678fabdde919824d6a0212bbc8bc099.tar.gz
master-187ad058-96216936f678fabdde919824d6a0212bbc8bc099.tar.bz2
master-187ad058-96216936f678fabdde919824d6a0212bbc8bc099.zip
ubox: fix kmod loading for modules with varying dashes & underscores in names (#14182, #14189)
Instead of canonicalizing module names in the internal avl tree simpyl use a custom strcmp() variant for the avl tree key comparisation. The custom comperator simply treats dashes and underscores the same, so "nls_iso8859-15" is equal to "nls-iso8859-15". This allows us to simplify the code considerably and makes manual "modprobe" invocations more forgiving when looking up the given module name. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38248 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/system')
-rw-r--r--package/system/ubox/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/system/ubox/Makefile b/package/system/ubox/Makefile
index f96c91bd32..021746d41b 100644
--- a/package/system/ubox/Makefile
+++ b/package/system/ubox/Makefile
@@ -1,13 +1,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ubox
-PKG_VERSION:=2013-09-17
+PKG_VERSION:=2013-09-28
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/luci2/ubox.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=cc07b0b7ac66d0e4a05470dd69a28305405cd7dd
+PKG_SOURCE_VERSION:=8baea575d7314f36649e7c85a90715e199dc0f46
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
CMAKE_INSTALL:=1