aboutsummaryrefslogtreecommitdiffstats
path: root/package/system
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2015-08-16 20:37:47 +0000
committerHauke Mehrtens <hauke@openwrt.org>2015-08-16 20:37:47 +0000
commit909154bae9da2f627878d80a8aee355f57cecd6a (patch)
treed732eeb29ece34915a2aa5418be14eba93ca0ee0 /package/system
parentcfb50ff8b4e8498cd55384480b7821936507cbb4 (diff)
downloadmaster-187ad058-909154bae9da2f627878d80a8aee355f57cecd6a.tar.gz
master-187ad058-909154bae9da2f627878d80a8aee355f57cecd6a.tar.bz2
master-187ad058-909154bae9da2f627878d80a8aee355f57cecd6a.zip
procd: fix seccomp build on some architectures
fix generating syscall-names.h Sometimes the syscall number is not defined with a number but with an offset to an other syscall and then make_syscall_h.sh created some broken header file. For example the bit/syscall.h from musl for i386 has this: #define __NR_timer_create 259 #define __NR_timer_settime (__NR_timer_create+1) With this patch the resulting array looks like this: [259] = "timer_create", [(__NR_timer_create+1)] = "timer_settime", This closes #20195. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46612 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/system')
-rw-r--r--package/system/procd/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
index a3b1481c25..2c7ea3bdcc 100644
--- a/package/system/procd/Makefile
+++ b/package/system/procd/Makefile
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=procd
-PKG_VERSION:=2015-07-27
+PKG_VERSION:=2015-08-16
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=370b68a9c3514ecb2fb6b814ba58e4e41f4f26c0
+PKG_SOURCE_VERSION:=0da5bf2ff222d1a499172a6e09507388676b5a08
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
CMAKE_INSTALL:=1