aboutsummaryrefslogtreecommitdiffstats
path: root/package/system
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-12-02 11:13:28 +0000
committerJohn Crispin <blogic@openwrt.org>2014-12-02 11:13:28 +0000
commit29d2573dfc02ba20fda2d30d240e64fd3078c460 (patch)
treef4e4a205506718c25bcc370d9ab8b300f4b2547d /package/system
parent03a9bf01b9b9b90674e40684beef8f2221cf6feb (diff)
downloadmaster-187ad058-29d2573dfc02ba20fda2d30d240e64fd3078c460.tar.gz
master-187ad058-29d2573dfc02ba20fda2d30d240e64fd3078c460.tar.bz2
master-187ad058-29d2573dfc02ba20fda2d30d240e64fd3078c460.zip
procd: add support for zram compressed /tmp
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43489 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/system')
-rw-r--r--package/system/procd/Makefile21
1 files changed, 15 insertions, 6 deletions
diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
index cbd2949448..27af3af97b 100644
--- a/package/system/procd/Makefile
+++ b/package/system/procd/Makefile
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=procd
-PKG_VERSION:=2014-11-19
+PKG_VERSION:=2014-12-02
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=02e1a4eac725aaae10c119ec2ec20d0da4a2c958
+PKG_SOURCE_VERSION:=e1a27d486c2374f46abd264f3fd6561815155ebd
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
CMAKE_INSTALL:=1
@@ -32,7 +32,7 @@ TARGET_LDFLAGS += $(if $(CONFIG_USE_EGLIBC),-lrt)
define Package/procd
SECTION:=base
CATEGORY:=Base system
- DEPENDS:=+ubusd +ubus +libjson-script +ubox +USE_EGLIBC:librt +libubox +libubus +NAND_SUPPORT:procd-nand
+ DEPENDS:=+ubusd +ubus +libjson-script +ubox +USE_EGLIBC:librt +libubox +libubus +NAND_SUPPORT:procd-nand +PROCD_ZRAM_TMPFS:kmod-zram +PROCD_ZRAM_TMPFS:e2fsprogs
TITLE:=OpenWrt system process manager
endef
@@ -51,13 +51,22 @@ config PROCD_SHOW_BOOT
bool
default n
prompt "Print the shutdown to the console as well as logging it to syslog"
+
+config PROCD_ZRAM_TMPFS
+ bool
+ default n
+ prompt "Mount /tmp using zram."
endmenu
endef
-PKG_CONFIG_DEPENDS:= PROCD_SHOW_BOOT
+PKG_CONFIG_DEPENDS:= PROCD_SHOW_BOOT PROCD_ZRAM_TMPFS
+
+ifeq ($(CONFIG_PROCD_SHOW_BOOT),y)
+ CMAKE_OPTIONS += -DSHOW_BOOT_ON_CONSOLE=1
+endif
-ifeq ($(CONFIG_PACKAGE_PROCD_SHOW_BOOT),y)
- CMAKE_OPTIONS += -DSHOW_BOOT_ON_CONSOLE
+ifeq ($(CONFIG_PROCD_ZRAM_TMPFS),y)
+ CMAKE_OPTIONS += -DZRAM_TMPFS=1
endif
define Package/procd/install