aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/procd
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-09-11 12:28:00 +0000
committerJohn Crispin <blogic@openwrt.org>2014-09-11 12:28:00 +0000
commitcee0fdae00c67ae1f32e8292e95859b908977194 (patch)
tree8061735c15e44099c20c57dc8a971d16f9b979d2 /package/system/procd
parent3caa9395b5c994b945767c8e528a2afdf24df35e (diff)
downloadmaster-187ad058-cee0fdae00c67ae1f32e8292e95859b908977194.tar.gz
master-187ad058-cee0fdae00c67ae1f32e8292e95859b908977194.tar.bz2
master-187ad058-cee0fdae00c67ae1f32e8292e95859b908977194.zip
procd: update to latest git
add support for starting services as !root Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42471 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/system/procd')
-rw-r--r--package/system/procd/Makefile4
-rw-r--r--package/system/procd/files/procd.sh4
2 files changed, 6 insertions, 2 deletions
diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
index 1f4d7d0a58..451b925eff 100644
--- a/package/system/procd/Makefile
+++ b/package/system/procd/Makefile
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=procd
-PKG_VERSION:=2014-08-29
+PKG_VERSION:=2014-09-09
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=6a6fa0a6067cb3c522f5dc735e808a68f62b30b2
+PKG_SOURCE_VERSION:=4bd633868e3284659668f14aa39ea84aaadc2dec
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
CMAKE_INSTALL:=1
diff --git a/package/system/procd/files/procd.sh b/package/system/procd/files/procd.sh
index e4e75edb2e..109daee64c 100644
--- a/package/system/procd/files/procd.sh
+++ b/package/system/procd/files/procd.sh
@@ -18,6 +18,7 @@
# file: configuration files (array)
# netdev: bound network device (detects ifindex changes)
# limits: resource limits (passed to the process)
+# user info: array with 1 values $username
#
# No space separation is done for arrays/tables - use one function argument per command line argument
#
@@ -139,6 +140,9 @@ _procd_set_param() {
nice)
json_add_int "$type" "$1"
;;
+ user)
+ json_add_string "$type" "$1"
+ ;;
esac
}