aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/procd
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-06-03 13:59:08 +0000
committerJohn Crispin <blogic@openwrt.org>2015-06-03 13:59:08 +0000
commitb224fbdca6c23630f6cf0edcca8d04ccc5219195 (patch)
tree9e4ec29aea9b873dfe0fe927b57174221d903862 /package/system/procd
parentc4a1d15d52fb053811f1e6ead73bc9663fc6e99b (diff)
downloadmaster-187ad058-b224fbdca6c23630f6cf0edcca8d04ccc5219195.tar.gz
master-187ad058-b224fbdca6c23630f6cf0edcca8d04ccc5219195.tar.bz2
master-187ad058-b224fbdca6c23630f6cf0edcca8d04ccc5219195.zip
procd: work around a event race
there is a conceptual design flaw in our interface events. workaround this by disabling duplicate message supression in procd. we need to fix this properly for the next release Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45883 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/system/procd')
-rw-r--r--package/system/procd/Makefile4
-rw-r--r--package/system/procd/files/procd.sh2
2 files changed, 2 insertions, 4 deletions
diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
index 44a836c4aa..9d66b0def5 100644
--- a/package/system/procd/Makefile
+++ b/package/system/procd/Makefile
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=procd
-PKG_VERSION:=2015-05-23
+PKG_VERSION:=2015-06-03
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=a771644fd3a3ac055ec0c62fbe434aed0df002fe
+PKG_SOURCE_VERSION:=94e7ea8b88cb01192a6fb1f1f6a68ada1356763f
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
CMAKE_INSTALL:=1
diff --git a/package/system/procd/files/procd.sh b/package/system/procd/files/procd.sh
index f3c7e48e50..0e798a0025 100644
--- a/package/system/procd/files/procd.sh
+++ b/package/system/procd/files/procd.sh
@@ -222,8 +222,6 @@ _procd_add_interface_trigger() {
json_close_array
json_close_array
-
- _procd_add_array_data "10000"
json_close_array
}