aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/procd/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-07-11 17:00:54 +0000
committerJohn Crispin <blogic@openwrt.org>2013-07-11 17:00:54 +0000
commitee1b454b4b845f1ef7d7a753e3f3e854da12f232 (patch)
treea2490dc7b2010b1179ec5111b09ec47b4168fbad /package/system/procd/Makefile
parentd20dabe8e8e100f06ade10e6c60b11564c17ff1e (diff)
downloadmaster-187ad058-ee1b454b4b845f1ef7d7a753e3f3e854da12f232.tar.gz
master-187ad058-ee1b454b4b845f1ef7d7a753e3f3e854da12f232.tar.bz2
master-187ad058-ee1b454b4b845f1ef7d7a753e3f3e854da12f232.zip
procd: add a small script that handles config reloads until configd is ready
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37248 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/system/procd/Makefile')
-rw-r--r--package/system/procd/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
index 27879e8443..b91af98146 100644
--- a/package/system/procd/Makefile
+++ b/package/system/procd/Makefile
@@ -32,6 +32,7 @@ define Package/procd/install
$(INSTALL_DIR) $(1)/sbin $(1)/lib/functions $(1)/etc/init.d
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/{procd,askfirst,udevtrigger,logread} $(1)/sbin/
+ $(INSTALL_BIN) ./files/reload_config $(1)/sbin/
$(INSTALL_BIN) ./files/log.init $(1)/etc/init.d/log
$(INSTALL_DATA) ./files/hotplug*.json $(1)/etc/
$(INSTALL_DATA) ./files/procd.sh $(1)/lib/functions/