aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/opkg
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-06-16 10:51:16 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-06-16 10:51:16 +0000
commitcbb70f7490a4827640662495fa4d0087f9191752 (patch)
tree55b2faec0ef6c11045ad4a36a84ff9abfccb632d /package/system/opkg
parent4ce5d87de4a67fe0d2361f3c84afa46ce8838757 (diff)
downloadmaster-187ad058-cbb70f7490a4827640662495fa4d0087f9191752.tar.gz
master-187ad058-cbb70f7490a4827640662495fa4d0087f9191752.tar.bz2
master-187ad058-cbb70f7490a4827640662495fa4d0087f9191752.zip
opkg: fix duplicate check_signature line for smime variant (#19863)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45999 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/system/opkg')
-rw-r--r--package/system/opkg/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/system/opkg/Makefile b/package/system/opkg/Makefile
index d313c442dd..d38ed52314 100644
--- a/package/system/opkg/Makefile
+++ b/package/system/opkg/Makefile
@@ -112,9 +112,6 @@ define Package/opkg/Default/install
$(INSTALL_DIR) $(1)/bin
$(INSTALL_DIR) $(1)/etc
$(INSTALL_DATA) ./files/opkg$(2).conf $(1)/etc/opkg.conf
- ifneq ($(CONFIG_SIGNED_PACKAGES),)
- echo "option check_signature 1" >> $(1)/etc/opkg.conf
- endif
$(call FeedSourcesAppend,$(1)/etc/opkg.conf)
$(VERSION_SED) $(1)/etc/opkg.conf
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/opkg-cl $(1)/bin/opkg
@@ -122,6 +119,9 @@ endef
define Package/opkg/install
$(call Package/opkg/Default/install,$(1),)
+ ifneq ($(CONFIG_SIGNED_PACKAGES),)
+ echo "option check_signature 1" >> $(1)/etc/opkg.conf
+ endif
mkdir $(1)/usr/sbin
$(INSTALL_BIN) ./files/opkg-key $(1)/usr/sbin/
endef