aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/ixp4xx-microcode/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-03-30 09:15:25 +0000
committerJohn Crispin <blogic@openwrt.org>2014-03-30 09:15:25 +0000
commitbbff25f740a1c4c9412fc0e7381eba266b261244 (patch)
tree6c2b4bcbc2e012ece0d1ae80e6adc52fb74fc72b /package/system/ixp4xx-microcode/Makefile
parent5e3b47eefcbb1bcf7c89df345d6197052960ed5f (diff)
downloadmaster-187ad058-bbff25f740a1c4c9412fc0e7381eba266b261244.tar.gz
master-187ad058-bbff25f740a1c4c9412fc0e7381eba266b261244.tar.bz2
master-187ad058-bbff25f740a1c4c9412fc0e7381eba266b261244.zip
firmware: create a new folder for holfing firmware blobs
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40307 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/system/ixp4xx-microcode/Makefile')
-rw-r--r--package/system/ixp4xx-microcode/Makefile57
1 files changed, 0 insertions, 57 deletions
diff --git a/package/system/ixp4xx-microcode/Makefile b/package/system/ixp4xx-microcode/Makefile
deleted file mode 100644
index 52b44f35f9..0000000000
--- a/package/system/ixp4xx-microcode/Makefile
+++ /dev/null
@@ -1,57 +0,0 @@
-#
-# Copyright (C) 2007 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=ixp4xx-microcode
-PKG_VERSION:=2.4
-PKG_RELEASE:=2
-
-PKG_SOURCE:=IPL_ixp400NpeLibraryWithCrypto-2_4.zip
-PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
-PKG_MD5SUM:=dd5f6482e625ecb334469958bcd54b37
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/ixp4xx-microcode
- SECTION:=net
- CATEGORY:=Network
- TITLE:=Microcode for the IXP4xx network engines
- DEPENDS:=@TARGET_ixp4xx
-endef
-
-define Package/ixp4xx-microcode/description
- This package contains the microcode needed to use the network engines in IXP4xx CPUs
-endef
-
-define Build/Prepare
- rm -rf $(PKG_BUILD_DIR)
- mkdir -p $(PKG_BUILD_DIR)
- unzip -d $(PKG_BUILD_DIR)/ $(DL_DIR)/$(PKG_SOURCE)
- mv $(PKG_BUILD_DIR)/ixp400_xscale_sw/src/npeDl/IxNpeMicrocode.c $(PKG_BUILD_DIR)/
- rm -rf $(PKG_BUILD_DIR)/ixp400_xscale_sw
- $(CP) ./src/* $(PKG_BUILD_DIR)/
-endef
-
-define Build/Compile
- (cd $(PKG_BUILD_DIR); \
- $(HOSTCC) -Wall -I$(STAGING_DIR_HOST)/include IxNpeMicrocode.c -o IxNpeMicrocode; \
- ./IxNpeMicrocode -be \
- )
-endef
-
-define Package/ixp4xx-microcode/install
- $(INSTALL_DIR) $(1)/lib/firmware
- $(INSTALL_DIR) $(1)/usr/share/doc
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/NPE-A $(1)/lib/firmware/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/NPE-A-HSS $(1)/lib/firmware/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/NPE-B $(1)/lib/firmware/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/NPE-C $(1)/lib/firmware/
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/LICENSE.IPL $(1)/usr/share/doc/
-endef
-
-$(eval $(call BuildPackage,ixp4xx-microcode))