aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/fstools
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-06-02 12:44:16 +0000
committerJohn Crispin <blogic@openwrt.org>2014-06-02 12:44:16 +0000
commit8cbc083fde18b844333536bfda31ded18091ffe1 (patch)
treec88818cb6354ef147f27fe53845bea5f37e5f443 /package/system/fstools
parent509bbab11e6de6fed7973d1da74bc671737b9719 (diff)
downloadmaster-187ad058-8cbc083fde18b844333536bfda31ded18091ffe1.tar.gz
master-187ad058-8cbc083fde18b844333536bfda31ded18091ffe1.tar.bz2
master-187ad058-8cbc083fde18b844333536bfda31ded18091ffe1.zip
fstools: stage libubi-utils static library and headers
Use InstallDev to make libubi-utils available for linking in uboot-envtools. Signed-off-by: Daniel Golle <daniel@makrotopia.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40928 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/system/fstools')
-rw-r--r--package/system/fstools/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/system/fstools/Makefile b/package/system/fstools/Makefile
index 40adf0af57..b10f105a74 100644
--- a/package/system/fstools/Makefile
+++ b/package/system/fstools/Makefile
@@ -78,6 +78,13 @@ define Package/block-mount/install
endef
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libubi-utils.a $(1)/usr/lib/
+endef
+
$(eval $(call BuildPackage,fstools))
$(eval $(call BuildPackage,ubi-flash))
$(eval $(call BuildPackage,block-mount))