aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/fstools/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2015-04-03 00:07:43 +0000
committerNicolas Thill <nico@openwrt.org>2015-04-03 00:07:43 +0000
commit9456cf255e95022d0c40afaf88c41177f9ac14c9 (patch)
tree686b0d657f68ac831587057ce6fdc54b3dfd511d /package/system/fstools/Makefile
parent1243352b6bf93a2fb72155ac45fd0e5116bb70ae (diff)
downloadmaster-187ad058-9456cf255e95022d0c40afaf88c41177f9ac14c9.tar.gz
master-187ad058-9456cf255e95022d0c40afaf88c41177f9ac14c9.tar.bz2
master-187ad058-9456cf255e95022d0c40afaf88c41177f9ac14c9.zip
packages: use $(LN) macro, make symlinks relative
Signed-off-by: Nicolas Thill <nico@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45250 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/system/fstools/Makefile')
-rw-r--r--package/system/fstools/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/system/fstools/Makefile b/package/system/fstools/Makefile
index f32ac2e35f..c76576640b 100644
--- a/package/system/fstools/Makefile
+++ b/package/system/fstools/Makefile
@@ -64,7 +64,7 @@ define Package/fstools/install
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{mount_root,jffs2reset,snapshot_tool} $(1)/sbin/
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libfstools.so $(1)/lib/
$(INSTALL_BIN) ./files/snapshot $(1)/sbin/
- ln -s /sbin/jffs2reset $(1)/sbin/jffs2mark
+ $(LN) jffs2reset $(1)/sbin/jffs2mark
endef
define Package/block-mount/install
@@ -76,8 +76,8 @@ define Package/block-mount/install
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/block $(1)/sbin/
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libblkid-tiny.so $(1)/lib/
- ln -s /sbin/block $(1)/usr/sbin/swapon
- ln -s /sbin/block $(1)/usr/sbin/swapoff
+ $(LN) ../../sbin/block $(1)/usr/sbin/swapon
+ $(LN) ../../sbin/block $(1)/usr/sbin/swapoff
endef