aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/ca-certificates/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-03-21 15:54:22 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-03-21 15:54:22 +0000
commitfb81974faf869c69471d33aec15b2dd67ba2318c (patch)
tree15408f3f0f05243bd7c1cfad0f6962283032218f /package/system/ca-certificates/Makefile
parent1abc9c63a29718c4686c2b7d49961e852adad879 (diff)
downloadmaster-187ad058-fb81974faf869c69471d33aec15b2dd67ba2318c.tar.gz
master-187ad058-fb81974faf869c69471d33aec15b2dd67ba2318c.tar.bz2
master-187ad058-fb81974faf869c69471d33aec15b2dd67ba2318c.zip
ca-certificates: add system CA certificates package (based on the debian one)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39984 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/system/ca-certificates/Makefile')
-rw-r--r--package/system/ca-certificates/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/package/system/ca-certificates/Makefile b/package/system/ca-certificates/Makefile
new file mode 100644
index 0000000000..f8fdf597fd
--- /dev/null
+++ b/package/system/ca-certificates/Makefile
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ca-certificates
+PKG_VERSION:=20140223
+
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.xz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/c/ca-certificates
+PKG_MD5SUM:=ff4049c32342ea450cda82bb14026ffd
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/ca-certificates
+ SECTION:=base
+ CATEGORY:=Base system
+ TITLE:=System CA certificates
+endef
+
+define Build/Install
+ mkdir -p \
+ $(PKG_INSTALL_DIR)/usr/sbin \
+ $(PKG_INSTALL_DIR)/usr/share/ca-certificates
+ $(call Build/Install/Default,)
+endef
+
+define Package/ca-certificates/install
+ $(INSTALL_DIR) $(1)/etc/ssl
+ ln -s ../../usr/share/ca-certificates $(1)/etc/ssl/certs
+ $(INSTALL_DIR) $(1)/usr/share/ca-certificates
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/ca-certificates/*/*.crt $(1)/usr/share/ca-certificates/
+endef
+
+$(eval $(call BuildPackage,ca-certificates))