aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/avila-wdt/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2012-10-17 22:45:58 +0000
committerJohn Crispin <blogic@openwrt.org>2012-10-17 22:45:58 +0000
commit16ed01db05cf25221a62baf3c8eba135f933a6b1 (patch)
tree405d52924fbc92967e8681bcca5e9c17d35aab8c /package/system/avila-wdt/Makefile
parent2372b1dbdb253065274b8a54846149d634bcea14 (diff)
downloadmaster-187ad058-16ed01db05cf25221a62baf3c8eba135f933a6b1.tar.gz
master-187ad058-16ed01db05cf25221a62baf3c8eba135f933a6b1.tar.bz2
master-187ad058-16ed01db05cf25221a62baf3c8eba135f933a6b1.zip
[kernel] move lots of kernel related packages to the new system/ folder
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33830 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/system/avila-wdt/Makefile')
-rw-r--r--package/system/avila-wdt/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/package/system/avila-wdt/Makefile b/package/system/avila-wdt/Makefile
new file mode 100644
index 0000000000..5bf6bf4ad0
--- /dev/null
+++ b/package/system/avila-wdt/Makefile
@@ -0,0 +1,40 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=avila-wdt
+PKG_RELEASE:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define KernelPackage/avila-wdt
+ SUBMENU:=Other modules
+ TITLE:=GPIO hardware watchdog driver for modified Avila boards
+ DEPENDS:=@GPIO_SUPPORT @TARGET_ixp4xx
+ FILES:=$(PKG_BUILD_DIR)/avila-wdt.ko
+ AUTOLOAD:=$(call AutoLoad,10,avila-wdt)
+endef
+
+MAKE_OPTS:= \
+ ARCH="$(LINUX_KARCH)" \
+ CROSS_COMPILE="$(TARGET_CROSS)" \
+ SUBDIRS="$(PKG_BUILD_DIR)"
+
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+ $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
+define Build/Compile
+ $(MAKE) -C "$(LINUX_DIR)" \
+ $(MAKE_OPTS) \
+ modules
+endef
+
+$(eval $(call KernelPackage,avila-wdt))