aboutsummaryrefslogtreecommitdiffstats
path: root/package/spca5xx-le
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2007-06-04 18:51:41 +0000
committerJohn Crispin <blogic@openwrt.org>2007-06-04 18:51:41 +0000
commitbfdde81495d6de18ef272919ace2bdcac6a13b18 (patch)
tree4f9dc6f474f6a9fe59954c8211146ded2de71390 /package/spca5xx-le
parentbb23d85b928ff44a12d5ce643277c2f118d6aace (diff)
downloadmaster-187ad058-bfdde81495d6de18ef272919ace2bdcac6a13b18.tar.gz
master-187ad058-bfdde81495d6de18ef272919ace2bdcac6a13b18.tar.bz2
master-187ad058-bfdde81495d6de18ef272919ace2bdcac6a13b18.zip
added light edition of spca5xx driver and the streamin server+web-applet
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7494 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/spca5xx-le')
-rw-r--r--package/spca5xx-le/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/package/spca5xx-le/Makefile b/package/spca5xx-le/Makefile
new file mode 100644
index 0000000000..82faba6b30
--- /dev/null
+++ b/package/spca5xx-le/Makefile
@@ -0,0 +1,44 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 7137 2007-05-08 18:40:02Z nbd $
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=spca5xx-le
+PKG_VERSION:=1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME).tar.bz2
+PKG_SOURCE_URL:=http://www.acmesystems.it/download/owrt/
+PKG_MD5SUM:=
+PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define KernelPackage/spca5xx-le
+ SUBMENU:=Other modules
+ DEPENDS:=@LINUX_2_6 kmod-videodev @VIDEO_SUPPORT
+ TITLE:=Driver for SPCA5xx based USB cameras (Light Edition)
+ URL:=http://mxhaard.free.fr/
+ VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
+ FILES:=$(PKG_BUILD_DIR)/spca5xx.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,90,spca5xx)
+endef
+
+define Build/Compile
+ $(MAKE) -C $(LINUX_DIR) \
+ ARCH="$(LINUX_KARCH)" \
+ CROSS_COMPILE="$(TARGET_CROSS)" \
+ KERNELVERSION="$(KERNEL)" \
+ KERNEL_VERSION="$(LINUX_VERSION)" \
+ KERNELDIR="$(LINUX_DIR)" \
+ SUBDIRS="$(PKG_BUILD_DIR)" \
+ modules
+endef
+
+$(eval $(call KernelPackage,spca5xx-le))