aboutsummaryrefslogtreecommitdiffstats
path: root/package/sipsak/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-05-19 21:23:30 +0000
committerNicolas Thill <nico@openwrt.org>2005-05-19 21:23:30 +0000
commit41386088d4d82bbf33c8bc222f4b41039ea7c652 (patch)
tree8356cd996e9487a04a4687c7cb665a0734ef3bf9 /package/sipsak/Makefile
parent3e38c0a21e40ab646d9ac2e292861fe1a09bd365 (diff)
downloadmaster-187ad058-41386088d4d82bbf33c8bc222f4b41039ea7c652.tar.gz
master-187ad058-41386088d4d82bbf33c8bc222f4b41039ea7c652.tar.bz2
master-187ad058-41386088d4d82bbf33c8bc222f4b41039ea7c652.zip
Tweak package build
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@975 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/sipsak/Makefile')
-rw-r--r--package/sipsak/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/sipsak/Makefile b/package/sipsak/Makefile
index 5adfc6af46..fc6e7fc54c 100644
--- a/package/sipsak/Makefile
+++ b/package/sipsak/Makefile
@@ -48,15 +48,15 @@ $(PKG_BUILD_DIR)/.configured:
--enable-shared \
--disable-static \
);
- touch $(PKG_BUILD_DIR)/.configured
+ touch $@
$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR)
+ rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
- install
- touch $(PKG_BUILD_DIR)/.built
+ all install
+ touch $@
$(IPKG_SIPSAK):
install -d -m0755 $(IDIR_SIPSAK)/usr/bin