aboutsummaryrefslogtreecommitdiffstats
path: root/package/rules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-04-14 04:27:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-04-14 04:27:05 +0000
commita25935134045da1cfa6d9cf1adb4c370e0fe02da (patch)
treef18c10164c89378fd730b186ff70a2d63b7f2329 /package/rules.mk
parent15a109de79716991457e9ffab1e352e20a7392c3 (diff)
downloadmaster-187ad058-a25935134045da1cfa6d9cf1adb4c370e0fe02da.tar.gz
master-187ad058-a25935134045da1cfa6d9cf1adb4c370e0fe02da.tar.bz2
master-187ad058-a25935134045da1cfa6d9cf1adb4c370e0fe02da.zip
port iptables to new config format, change handling of TITLE and DESCRIPTION
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3647 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/rules.mk')
-rw-r--r--package/rules.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/package/rules.mk b/package/rules.mk
index 0920f7bcf3..c2f0a34511 100644
--- a/package/rules.mk
+++ b/package/rules.mk
@@ -56,13 +56,13 @@ IPKG_$(1):=$(PACKAGE_DIR)/$(1)_$(VERSION)_$(PKGARCH).ipk
IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg/$(1)
INFO_$(1):=$(IPKG_STATE_DIR)/info/$(1).list
-ifneq ($(BR2_PACKAGE_$(1)),)
+ifneq ($(PACKAGE_$(1)),)
compile-targets: $$(IPKG_$(1))
endif
ifneq ($(DEVELOPER),)
compile-targets: $$(IPKG_$(1))
endif
-ifeq ($(BR2_PACKAGE_$(1)),y)
+ifeq ($(PACKAGE_$(1)),y)
install-targets: $$(INFO_$(1))
endif
@@ -78,7 +78,8 @@ $$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.prepared
echo "Priority: $$(PRIORITY)" >> $$(IDIR_$(1))/CONTROL/control
echo "Maintainer: $$(MAINTAINER)" >> $$(IDIR_$(1))/CONTROL/control
echo "Architecture: $$(PKGARCH)" >> $$(IDIR_$(1))/CONTROL/control
- echo "Description: $$(DESCRIPTION)" >> $$(IDIR_$(1))/CONTROL/control
+ echo "Description: $$(TITLE)" >> $$(IDIR_$(1))/CONTROL/control
+ echo "$$(DESCRIPTION)" | sed -e 's,\\,\n ,g' >> $$(IDIR_$(1))/CONTROL/control
chmod 644 $$(IDIR_$(1))/CONTROL/control
for file in conffiles preinst postinst prerm postrm; do \
[ -f ./ipkg/$(1).$$$$file ] && cp ./ipkg/$(1).$$$$file $$(IDIR_$(1))/CONTROL/$$$$file || true; \