aboutsummaryrefslogtreecommitdiffstats
path: root/package/resolveip/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-10-10 12:32:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-10-10 12:32:29 +0000
commitabe70b1494c60a3f9cbe5e4d8d967a82dd1e29a5 (patch)
tree46b83031a0da1b4458317413c00d13c252c72afa /package/resolveip/Makefile
parent41d09b7d7880b83b0e544574296b2b3673792c7f (diff)
downloadmaster-187ad058-abe70b1494c60a3f9cbe5e4d8d967a82dd1e29a5.tar.gz
master-187ad058-abe70b1494c60a3f9cbe5e4d8d967a82dd1e29a5.tar.bz2
master-187ad058-abe70b1494c60a3f9cbe5e4d8d967a82dd1e29a5.zip
packages: sort network related packages into package/network/
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33688 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/resolveip/Makefile')
-rw-r--r--package/resolveip/Makefile44
1 files changed, 0 insertions, 44 deletions
diff --git a/package/resolveip/Makefile b/package/resolveip/Makefile
deleted file mode 100644
index 6ab04e162e..0000000000
--- a/package/resolveip/Makefile
+++ /dev/null
@@ -1,44 +0,0 @@
-#
-# Copyright (C) 2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=resolveip
-PKG_RELEASE:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/resolveip
- SECTION:=utils
- CATEGORY:=Base system
- TITLE:=Simple DNS resolver with configurable timeout
-endef
-
-define Package/resolveip/description
- This package contains the small resolveip utility which
- can be used by scripts to turn host names into numeric
- IP addresses. It supports IPv4 and IPv6 resolving and
- has a configurable timeout to guarantee a certain maximum
- runtime in case of slow or defunct DNS servers.
-endef
-
-define Build/Prepare
- $(INSTALL_DIR) $(PKG_BUILD_DIR)
- $(INSTALL_DATA) ./src/resolveip.c $(PKG_BUILD_DIR)/
-endef
-
-define Build/Compile
- $(TARGET_CC) $(TARGET_CFLAGS) -Wall \
- -o $(PKG_BUILD_DIR)/resolveip $(PKG_BUILD_DIR)/resolveip.c
-endef
-
-define Package/resolveip/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/resolveip $(1)/usr/bin/
-endef
-
-$(eval $(call BuildPackage,resolveip))