aboutsummaryrefslogtreecommitdiffstats
path: root/package/procd/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-04-03 10:01:10 +0000
committerJohn Crispin <blogic@openwrt.org>2013-04-03 10:01:10 +0000
commit52a91b390ad7606d026ba92ccf6b407867ba1fed (patch)
treecb53cea4199e2c3a7d463dd9977d339aa6d84dc3 /package/procd/Makefile
parent0f8a260d4b085fd95fb2fbb584e509dadd337875 (diff)
downloadmaster-187ad058-52a91b390ad7606d026ba92ccf6b407867ba1fed.tar.gz
master-187ad058-52a91b390ad7606d026ba92ccf6b407867ba1fed.tar.bz2
master-187ad058-52a91b390ad7606d026ba92ccf6b407867ba1fed.zip
[procd] fix eglibc compile
add librt dependency/link flag to procd when using eglibc thanks to jow for the help Signed-off-by: Etienne CHAMPETIER <etienne.champetier@free.fr> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36188 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/procd/Makefile')
-rw-r--r--package/procd/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/procd/Makefile b/package/procd/Makefile
index 762fb5f18f..53c102a7cb 100644
--- a/package/procd/Makefile
+++ b/package/procd/Makefile
@@ -21,10 +21,12 @@ PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
+TARGET_LDFLAGS += $(if $(CONFIG_USE_EGLIBC),-lrt)
+
define Package/procd
SECTION:=base
CATEGORY:=Base system
- DEPENDS:=+ubusd +ubus +libjson-script
+ DEPENDS:=+ubusd +ubus +libjson-script +USE_EGLIBC:librt
TITLE:=OpenWrt system process manager
endef